Homekit, ecobee, HA local control question

So I did not realize until today, that apparently Ecobee has local control with Homekit. So even if the internet is down, you can control your ecobee with homekit. I have an apple TV, I use it for two HA input booleans, and not much else. I have my ecobee set up in HA using the HA component.

Anyway my question is: If I add my ecobee to Homekit, and remove the HA component, then discover the Ecobee via the homekit controller component, will I have local control of the ecobee?

I saw some posts on this, but it seemed like it either did not work or was buggy. I have a few automations that change the mode of my ecobee, and honestly it rarely fails, but having 100% local control of the ecobee would be nice, just in case.

1 Like

Great question! After Ecobee servers were recently down I was wondering the same.

Although I have no Apple devices I have my Ecobee3 thermostat setup paired via Homekit with HA using the homekit_controller component. The reason is, as you say, the homekit connection is local.

Problem is that the initial pairing feature in HA homekit_controller is broken for devices like ecobee that generate a new pairing pin for each attempt. The problem is being worked on as you can see here https://github.com/home-assistant/home-assistant/issues/15336#issuecomment-469365960 and you really want ‘pairing now’ you could follow the steps in that link. It would be better to wait until the problem is solved I think.

Thanks, I came across that issue this weekend, after a couple of hours if messing around with no success I gave up. But will wait until the issue is resolved. I also seem to have issues in general with my ecobees and homekit. Even pairing to my apple tv ended up having continous issues with losing connection. Even though my network seems solid, I dont know if there is something else going on.

Even when trying to pair to HA using the component, running “python -m homekit.discover” often did not show my ecobees, then would show them, then a few minutes later they would disappear. I’d be in the middle of trying to pair and it would seem like something was wrong, I’d run the discover command again and they would not be there. But like I said, it seemed to my like my apple tv had similiar issues. They were available then not available. etc.

I found several posts online about similiar issues, but also found people who said everything worked fine.

1 Like

Jc2k has made great progress on homekit ecobee setup. Check out the recent post on git for updated steps. Works great here.

1 Like

I “added” my ecobee’s using the steps, but HA still does not seem them as added. If I enter a pin in the UI it does say they are already paried. I did pair the thermostats and sensors using the command line, and when I do a discover I do see them as paired. What do I need to do for HA to recognize the command line pairing. I’ve restarted

I noticed that when I restarted HA that

homekit_python/archive/master.zip

seems to revert to the previous version vs .14. Not sure if that’s an issue or not, but probably, right?

Did you generate a paring.json file and where is it located?

I’ve had it in my root home folder and also i put it in the .homekit folder. It has all the info for my ecobees and sensors

Did you rename the AccessoryPairingID as instructed in this step? The python CLI uses the Ecobee’s name as the Pairing ID, but HA uses the device’s MAC address.

I did not. I was actually a bit confused by that to be honest.

So

{
  "ecobee": {
    "AccessoryPairingID": "ff:f0:00:00:00:00",

should look like this??

{
  "ff:f0:00:00:00:00": {
    "AccessoryPairingID": "ff:f0:00:00:00:00",

Of course with my pairing ID

Correct. Then restart HA.

1 Like

I was able to pair an Ecobee 3 Lite to HA today! The first time during the pairing HomeKit failed with an exception, and when I tried again everything paired and the thermostat and remote sensors appeared in HA. I’m running v0.94

I switched my Ecobee 4 over to local control via homekit recently, but I see that the Ecobee Mode is no longer available (Home, Away, Sleep, etc). Anyway to add this back in? I don’t see it under the listed attributes.

I don’t believe those are available at the moment. I have the same “issue” as you. From reading other posts I have seen that this is the norm. What I have done is setup both local control and “ecobee” integration. I use the local control for my thermostat and temp/motion sensors in my automations and Lovelace. I use the ecobee integration for setting modes. But I only have a couple automations that do that. It’s not optimal, but it puts the local control where I need it.

Thanks ptdalen, I ended up just doing the same. I have my ceiling fans and fireplace setup to operate based on the ecobee mode so it totally messed up all of my automations. Hopefully this is something that gets integrated into the local control in the future.

I’m thinking of moving from Nest to Ecobee after their API disasters.

I would love to add the Ecobee 4 via Homekit to achieve local control - I suppose that is reliably possible right now? Will that also add the occupancy sensors to HA? A while ago I read that Ecobee can only do 7 sensors when being used in Homekit mode? Is that still accurate?

Thanks

If love to get ecobee connected over homekit. Frequent home assistant reboots often lose pairing, plus we want local control. Aside from the defect tracker, has anyone come across a pairing tutorial?

You can easily configure this via the Integrations page in the UI. Just create a new integration, choose the “Homekit Accessory” option and it should find your ecobee. It was very straightforward to setup, I got rid of the cloud entities shortly after and haven’t looked back.

Thanks so much!

I had my Ecobee paired with an old, unused iPhone so it never appeared in my Home Assistant HomeKit discovery list. Unpaired, re-scanned and it works! Local control!

Do you have same issue in heat/cool you can’t setup min and max temp only sort of avarage is available…