Homekit for mac docker

Basically new to HASS and completely new to docker, so please do dumb things down for me.

I tried installing HASS on my Mac docker following this guide, after changing my time zone and config path. Everything seems to be working fine. Problem is I can’t get HASS to be added to homekit as a bridge. I get the accessory QR code and scan it with my phone, but it just keeps trying to connect and eventually I get a message saying “accessory not found”. When I ran home assistant os on my RPI homekit connects just fine (but I have a ton of other problems with that, which I’ll probably save for another post, so I switched to running it on a Mac docker instead).

Things I’ve tried:

  1. Adding Homekit integration via the UI, with and without auto-start
  2. Adding Homekit to my config.yaml file, after removing the UI version. My relevant portion of the config file is as follows:
  port: 51827

for the port I tried 51827 and 51828, not that either of them was being used.
3. Installing HASS via docker run --init -d --name="home-assistant" -e "TZ=America/Los_Angeles" -v /PATH_TO_YOUR_CONFIG:/config --net=host homeassistant/home-assistant:stable, but I couldn’t log into the localhost:8123 after that.

Thank you! Again, please feel free to dumb things down for me.