Homekit for Wyze Cam v2

Tags: #<Tag:0x00007f739b3f4da8>

Hi, I was looking around in the forums, looking for a integration that works with the Wyze RTSP function but nothing worked for me.

Can someone please suggest a integration that works with them through Home Assistant and shows up in Homekit?

camera:
  - platform: ffmpeg
    name: Basement Sump Pit
    input: -rtsp_transport udp -i rtsp:/username:[email protected]/live

You have to look in the Wyze app or your router what the IP Address, username and password are.
To add to Homekit just use the new bridge integration!

Thank you for the quick reply.

I tried it out and it works 100% in Home Assistant, but when I enter Homekit it shows almost like a still image, but doesn’t show the live feed and sometimes will display, that I have to wait for someone else to stop watching the stream? I am using my Wyze Cam to monitor my garage doors and it works to look if the door is open or closed, but would appreciate it if you could maybe look into it if it’s maybe just my slow internet speed or a problem in the code.

Kind regards,
Pierré

Have you clicked on the video?
It updates a screenshot every 10 seconds on the main pages but when I click it it plays live video after a few seconds.

Yes, when I click on the video it shows “live” but I can see by the time watermark in the bottom right hand corner it only shows a still image.

But sometimes it will slowly show as the time goes by.

What type of device is this all running on?
A raspberry Pi?

Yes, you think that may be the problem?

It’s a Raspberry Pi 4 with 4gb of ram.

I’ve heard those are pretty powerful but I stopped using my Pi a long time ago because whenever I tried to do anything with video (this was with HOOBS mind you) it would be very choppy. A new codec came out called OMX or something like that that is faster but had a lot of pixelation, again this was just for HOOBs but now that plugin is gone for my Nest cam…

Now I run on a 2012 Mac Mini with 16GB of RAM.
Home Assistant is on a virtual machine but it runs video much faster.
HOOBS is running on a Docker Container directly on my Mac.
There is an RTSP Plugin for Homebridge/HOOBS that supports the OMX codec, you can try that on your Pi if you can’t afford any beefier hardware.

Can you maybe send a URL on how to install the RTSP plugin?

For HOOBS? It’s real easy, you just search for it.
For Homebridge I installed the one with the Web UI back in the day which also had a nice search feature.
Here’s a link to install Homebridge with a Web UI on a PI:

I personally prefer HOOBS these days but I can’t get my container running on Mac to be added to Homekit for some reason… With the recent additions to Homekit on HA I don’t have much need for it but I like to have it for things that HA can’t get like smooth video on my Nest Doorbell which I still haven’t figured out.

Thank you, I will try it out.

I only use Home Assistant, because my Sonoff devices doesn’t work well with Hoobs.

1 Like