Homekit integration don't discover my somfy tahoma switch


make the big jump yesterday and installed HAOS on proxmox, all went well so far and added a few integration (samsung tv, printer, Sonos)

today decided to get a bit further and bought a somfy tahoma switch (conectivity kit was out of stock)

  • installed the app on my android phone
  • paired all my io roller and velux windows in the app
  • configured overkiz integration (cloud)
    now I can move my roller from somfy app and from HA, good :slight_smile:

then, as I’ve read that we can also configure the homekit integration to have a fallback local command for the roller, I tried to install the homekit integration.
And here is my problem… the tahoma switch is not discovered at all and I didn’t find a way to force it :confused:

The tahoma switch is on the same lan (via wifi) as the HAOS vm (wired lan)
According to the different topics I’ve read the tahoma should pop and be discovered automagically by the homekit integration
Is someone have some idea here of what is going wrong here ?

Note: not sure if it’s relevant, but I also activated the developper local api of the tahoma(but didn’t use it for now)

Solved my issue…
rebooting the tahoma (unplug / plug the usb power supply) make the homekit discover integration to pop, and I was able to configure it.

never rebooted the tahoma after the initial setup and roller pairing, seems that’s necessary to make the homekit service to initialize