Homekit - No Response - 2022.8

Been using HomeAssistant for several years now and had it all working with Homekit just fine back when it was .1x release. Recently ugpgraded to 2022.8 release and now having issues with Homekit so I’m starting from scratch.

I already have my yaml for homekit so I’d like continuing to use that. AppleTV 4K. Everything connected to a consumer TP Link router.

Deleted and then re-added Homekit in the HA Settings/Devices Add Integration (“Homekit”). Restarted HASS (just to make sure). Added Bridge to iPhone Home app using QR Code - it found all my devices (including cameras) just fine and everything looked great. Even cameras showing footage correctly.

But as soon as I try to turn on/off a light, I get “No Response” message in iPhone Home app and then things fall apart and start to not work. I have a pretty small setup (3 cameras, 3 lights, 2 switches, alarm).

Tried a million different ways/multiple times (config via UI, via YAML) and cannot seem to figure this out. Any help appreciated. Setup bridge works fine, then nothing works after that.

1 Like

For anyone who might stumble across this, it turns out I had an issue with one of my AppleTVs. I have 2 AppleTVs in the house and one of them was connected to a different wifi. Somehow this messed up the Homekit configuration. I removed that AppleTV from acting as a Homekit Hub and the problem went away.


I’m facing the same issue. How did you remove Apple TV from acting as a hub?

Edit: I didn’t consider the possibility to do it from the Apple TV , I just had to go to settings > HomeKit and I disconnected it as a hub. It looks like everything is working again. I hope it will keep on working fine, but I think it’s not normal.

Yes - I disconnected it via the AppleTV. Settings > Airplay & Homekit > Home Hub —> change to disabled on one of my Apple TVs

Late in the thread but it solved my problem even though it was a really edge case. For some one else running a weird setup, my AppleTV was connected to a different SSID, which is a VPN. Disabling it as the hub (and moving the hub function to a HomePod) solved it. More info here.

Just thought I’d update as I just experienced something similar today.

Noticed that all of the devices on HomeKit, linked from HA using the HomeKit Bridge integration, were displaying as ‘No Response’. Checked the integration on HA and all looked to be healthy, also reloaded it but no change on HomeKit.

Checked on HomeKit and saw that one of the Apple TV’s, acting as a Home Hub, was displaying as unresponsive under Home Settings → Home Hubs & Bridges. I have multiple devices acting as Home Hubs, with one displaying the ‘Connected’ status and the others displaying the ‘Standby’ status, with one showing as unresponsive.

Once I had restarted the unresponsive Apple TV, all of the devices came back online and were able to be controlled from HomeKit.

It looks like there’s an issue with Apple HomeKit’s Home Hub’s causing issues with the config if one of them goes offline or changes network.

This helped me realize my issue – my AppleTV was connected to a switch in between it and the router, so it was basically on a different network. Unplugging the ethernet on the AppleTV and setting it to use wi-fi immediately fixed my issues. Thanks!