HomeKit - no way to remove old/disabled devices from list in UX

In the HomeKit bridge config editor, in the UX, it lets you choose items in a dropdown - however I have some older ones that used to exist and no longer do, and so the checkboxes don’t render in the dropdown, and the items still show in the list. Attempting to save results in an “invalid input” kind of error message.

Is there a way to edit the configuration for the HomeKit add-on when you did the configuration in the UX?

Thanks in advance.

From the command line, go into /config/.storage and search for the entities that are in core.config_entries, remove the lines and then restart HA. That should fix it (I did it earlier today).

1 Like

Be careful editing those files.

they aren’t meant to be user editable and if you mess up the syntax you will break your HA.

Make a backup!

Via this method it appears to be a two-step process.

  1. Edit /config/.storage/core.config_entries and remove the device identified by homekit
  2. Edit /config/.storage/core.entity_registry and remove each entity created for the device
    Quite a lot of very careful editing.

Perhaps this is a newer feature than the original thread (now two years old).
First Delete the device in homkit. If it disappears you are done and this probably how its supposed to work.
But if it does not disappear and is just grey with a ! mark, visit the device’s page within homkit integration. All the entities will be unavailable. Remove each of the entities in the Device by clicking on each entity, click the settings cog. You should see dialog reporting that the entity is no longer provided by the homkit_controller integration. Now click DELETE in bottom corner.
Remove all entities like this. Then return to the homekit screen and disable the entity and then delete the entity. That got rid of it for me.
I think my problem was I hard reset the device to clear and re-install it. I think I should remove it from homekit before doing this.