HomeKit problems in 0.68

Hi all,

Am I the only one experiencing problems with the “regular” HomeKit-component in 0.68?
I updated from 0.67, where it worked fine, to 0.68. When I look in my Home-app on my phone, it just says that “Home Assistant is not responding.”
Tried to delete Home Assistant from my Home app and reinstall, but even though I could see it and enter the 8-digit code it would not pair.

Tried to downgrade to 67.1, and then everything works again.
Updated to 0.68 AGAIN - and no luck :slight_smile:

Anyone with the same experiences?

Best regards

Not completely solved, but got a little progress.

It seems that one or more of my entities are blocking HomeKit. When I e.g. only include my garage door, it starts up. So it’s probably a local error :slight_smile:

add more logging to the start up:

  default: warning
    homeassistant.components.homekit: debug
1 Like

I had the same issue. I deleted the .homekit.state file as mentioned here and then it worked again.

I did that several times without any luck. But after adding the entities one by one, I have not had any issues - and it also gives me a cleaner interface - so I’m happy :slight_smile: