Homekit took 7 hours to detect device

I installed the meross MSG100HK as I saw some other HA users had set it up successfully with local connectivity via Homekit.
I have no other homekit devices, so this process was new to me… but I imagine it should not have taken 7 hours for the device to show up in HA for configuration.

Things I tried when it did not immediately show up:

  • Adding it to the apple home app on my wife’s iphone
    -This worked immediately and without issue. I removed it from the apple home app after testing functionality.
  • Verified that it showed up under the ‘bonjour’ list on a network analyzer app on my phone.
  • Confirmed all updates installed.
  • Confirmed zeroconf was enabled.
  • Tried changing default interface for integrations.
  • Tried enabling/disabling ipv6
  • Enabled debug logging for zeroconf and looked for anything unusual (found nothing)
  • Reset and power cycled the MSG100HK after reconnecting it to wifi.
  • Running HA in safe mode

Eventually I gave up and went to bed, but was surprised to see this morning that the device was in my settings awaiting configuration! And it works just fine.

According to the logs, it showed up about 7 hours after the last reboot.

Did I do something wrong?

raspberry pi 4 running image from rpi imager

  • Core 2024.5.0
  • Supervisor 2024.04.4
  • Operating System 12.2
  • Frontend 20240501.0

Logs: home-assistant_2024-05-02T13-52-55.699Z.log - Google Drive
Bonjour Device List: Imgur: The magic of the Internet