Homematic ccu3


#1

hi all,

as the latest version of homematic´s ccu3 is now available, i am reaching out the homematic people here. my expectation would be to get it integrated with HASS without problems as the underlying communication stack is still the same, just on top of new hardware.

did anyone already try it?

@danielperna84 maybe you got some background to share already :slight_smile:

regards,
markus


#2

I don’t have one and probably won’t get one. But I assume the XML-RPC API is still available, so I don’t think any changes are required. Maybe resolving names via JSON-RPC stops working. But since HASS 0.77 HomeMatic supports the entity registry, so resolving names isn’t that important because you can rename your devices however you want.


#3

I made my own CCU3 with a Raspberry Pi 3 and the new RPI-RF-MOD card and RaspberryMatic. It works very well and is considerably faster than the old CCU2. Integration with HA is greatly aided if you install the XML-API plugin on the CCU and use the - resolvenames: xml in your configuration.yaml

The only problem I have is rebooting the CCU drops the connection with HA. However,once I got it setup it’s been rock solid.


#4

That’s normal. HA does not automatically reconnect because the XML-RPC API does not provide a native way of pinging it to see if it’s online. You an use an automation as a workaround as explained in the documentation.


#5

I saw that, but I decided not to use it as I was simply replacing a fully configured CCU2 with a CCU3. Once it was setup, I haven’t had to reboot it. I’m still getting my HA server configured so that get restarted/rebooted quite often.


#6

In the long run though it is still useful. Just yesterday the power went out for half a second. My Raspberry with HA running on it is powered through a power bank, so it didn’t shut down. The CCU2 however went offline, and because I didn’t have the automation everything related to HomeMatic stopped working. :wink:


#7

Good point. I’ll have a go at it this weekend.


#8

That sounds great! :slight_smile:

Can you pls. post your configuration.yaml (or least parts of it)?
Do all HM device show up automatically in HA?

  • Alex

#9

Here’s the configuration.yaml

homematic:
  interfaces:
    rf:
      host: 192.168.16.13
      resolvenames: xml
    ip:
      host: 192.168.16.13
      port: 2010
      resolvenames: xml
  hosts:
    ccu2:
      host: 192.168.16.13

You need to install the XML-API addon on the CCU and your devices should appear automatically.


#10

Thx!
Since I don’t see any usage of username/password, I assume you have authentication disabled. Am I right?


#11

btw I have been using the original CCU3 for two months now and did not notice any impacts or differences in terms of the HA integration.


#12

There shouldn’t be any change, I have switched to a Tinker Board S with RaspberryMatic and apart from the speed increase, the change was seamless.


#13

It is not recommended to use the XML-API for resolving names. The CCU always has JSON available out of the box. The XML-API is just a remnant from the early days of the Home Assitant integration for HomeMatic and might get disabled in the future because it has no advantages over the JSON-solution.

Regarding the topic itself: the CCU3 is fully compatible. Home Assistant also gained support for authentication and SSL with the CCU3 a few releases ago. So from a security standpoint the CCU3 / RaspberryMatic should be favoured over the CCU2.


#14

I’m using HassIO version 142 and RaspberryMatic 3.41.11.20181126.
Am I right that RaspberryMatic corresponds to CCU3?

This is my config:
homematic:
interfaces:
rf:
host: 192.168.111.XXX
resolvenames: json
username: alex
password: XXX
ip:
host: 192.168.111.XXX
resolvenames: json
username: alex
password: XXX
port: 2010
groups:
host: 192.168.111.XXX
port: 9292
username: alex
password: XXX
path: /groups
resolvenames: json
hosts:
abydos:
host: 192.168.111.XXX
username: alex
password: XXXX


#15

Yes. And with the correct settings on RaspberryMatic your config should work just fine.


#16

It works after allowing incoming connections in the FW.

Thx for your help!


#17

@danielperna84 I decided to take your advice and move to json name resolution, but i can’t get it to work on hass.io. I setup a test docker install of HA, and all I get is the serial numbers of devices. XML-API works fine.
Any ideas?


#18

Make sure you have setup the firewall on the CCU properly. Like this:


Und the user that you have setup needs sufficient privileges.


#19

Thank you for the reply. I had “Ports open”, “Full access”, “Full access” and “Full access” on the firewall, which I thought would avoid problems connecting. I changed them to your settings but no difference. The user Guest is admin and I use callback_ip and callback_port as HA runs under docker. Here is the configuration.yaml I use:

homematic:
  local_ip: 192.168.16.22
  local_port: 8686
  interfaces:
    wireless:
      host: 192.168.16.13
      port: 2001
      callback_ip: 192.168.16.22
      callback_port: 8686
      resolvenames: json
      username: Guest
      password: xxxxx
    rf:
      host: 192.168.16.13
      port: 2001
      callback_ip: 192.168.16.22
      callback_port: 8686
      resolvenames: json
      username: Guest
      password: xxxxx
    ip:
      host: 192.168.16.13
      port: 2010
      callback_ip: 192.168.16.22
      callback_port: 8686
      resolvenames: json
      username: Guest
      password: xxxxx
    groups:
      host: 192.168.16.13
      port: 9292
      callback_ip: 192.168.16.22
      callback_port: 8686
      resolvenames: json
      username: Guest
      password: xxxxx
      path: /groups
  hosts:
    ccu3:
      host: 192.168.16.13
      username: Guest
      password: xxxxx

#20

The callback IPs and ports are irrelevant for resolving the names. Please set the loglevel like this and post the output:

logger:
  default: warning
  logs:
    homeassistant.components.homematic: info
    pyhomematic: info

If that doesn’t show enough you might even have to switch to the debug level.