Homematic events not registering

Hey everyone,

I have problems regarding the Homematic-integration, more specifically its events;
I’m pretty new to Home Assistant overall, therefore I’m not even sure if I have a problem at all or if I just haven’t correctly understood all the basic principles, so I hope you cut me some slack if this is the case.

I run Home Assistant 0.98.2 in Docker on a Raspberry Pi 3 and used the Homematic-integration to access my Homematic CCU3 running on the same Pi but on a different IP address:

      username: ###
      password: ###

This worked great to include entities for my Homematic thermostat, several door/window sensors and a dimmer switch (although the status of the dimmer seems to sometimes not update reliably, but that’s not the problem I’m here for).

I now have a new HM-SwI-3-FM switch connected to my CCU3 that I want to use as a trigger for automations. If I understand the documentation correctly the switch should generate Homematic.Keypress or Homematic.Impulse events when activated. To just get a sense how these look and what data they contain (like I said, I’m a beginner), I used the event-subscription feature in the events-section of the frontend to listen for Homematic.Keypress and Homematic.Impulse (and also for Homematic_Keypress and Homematic_Impulse because I wasn’t sure which ones are correct) events when pressing the switch. But none appear, not only when activating the new switch, but also not after I went round and frantically pressed every button on every Homematic-component I have, both physically and virtually in the CCU.

Now, am I severely misunderstanding how these events or events in general work, and if yes, what am I doing wrong? Or is there a reason why my Home Assistant doesn’t register any events coming from Homematic, and if yes, what can I do?

I hope this even is the right category for this topic, sorry if it isn’t. Either way, thank you all very much in advance!

Did you figure this out? If not, the capitalization you’re doing for the events might be a problem. It’s homematic.keypress, not Homematic.Keypress. You should use the exact same format as described in the documentation.