Homematic hat Issue with Alpine based hassio (ResinOS works like a charme)

Hi folks,

I’m using hass.io since 0.7x or maybe earlier and updated the same image up to the current version 0.102.3
I’m using it with several hardware addons like Zigbee or Zwave (both USB) and one Raspberry PI Hat for Homematic (not IP!) on a Raspberry 2 and 3 and everything is working like a charme.

But now I wanted to switch to a new SD card due to capacity problems but it failed because the new hass.io Image seems to cause problems.

I downloaded the latest hass.io Image and flashed with Etcher, took a snapshot from my existing installation and after restore everything except Homematic works on the same Raspberry.
If I take a copy of the old SD card with “dd” and write it to a new card and restore the same snapshot all works even Homematic.

What I now is that the Linux from the image has changed to speed up hass.io (which is really working) but may this change is causing trouble? Does anybody use the new image with the Homematic (not IP!) hat successfully on a Raspberry without any trouble?
I tried it already several times in various setups even with another Pi but none worked until now.

Thank you very much for any reply.


Update with further Details:

Root cause seems to the changed core linux from ResinOS to Alpine linux. With Alpine linux the Bidcos Interface of the Homematic hat is not working anymore - does anybody have an idea how to fix that?
Or should I open an issue at the Developers?

You’re confusing the layers.

ResinOS was the HOST operating system. It didn’t change to Alpine. It changed to HassOS which is based on BuildRoot.

The DOCKER image changed to Alpine Linux.

You need to figure out if the problem exists at the HOST level (HassOS) or the container level (Alpine Linux + Home Assistant). The host should be passing through all devices connected to it.

Okay, thank you for the clarification!
The probelm exist since 0.98 where the container changed to Alpine. So it might be the container level?

If the problem started with the image changing to Alpine, then the culprit is probably at the container level, and likely needs some libraries installed in the image. I would open an issue with the developers and see if they can add the libraries needed.

Yes, seems to be the best. Thanks a lot!