Homematic HmIP-RCV-50 not working with virtual key any more

Hi everybody,

since the august update 3.53.26 of my CCU3 (now on 3.53.34, HA on 0.118.2) I can’t trigger the buttons of the HmIP-RCV-50 anymore.

E. g. when I call the following script, nothing happens:

    - service: homematic.virtualkey
        address: HmIP-RCV-50
        channel: 20
        param: PRESS_SHORT

But there is a log entry in the logs stating:

2020-11-25 19:48:03 ERROR (SyncWorker_2) [homeassistant.components.homematic] HMIP-RCV-50 not found for service virtualkey!

Unfortunately, that all worked before the update.

When I go to the ccu, I’m able to press any button on the HmIP-RCV-50 without problems.

I heard of that update renaming the HmIP-RCV-50. But in the ccu I can execute the following script successfully:

object obj = devices.Get("HmIP-RCV-50");
if(obj) {
else {
  WriteLine("not found");

It states, that the device is found by name.

Perhaps I’m missing something out or someone else was in a similar situation and found a solution. So it would be great, if anyone could help me.



I’m experiencing exactly the same Problem. I tried to invoke a virtual button on the CCU with different adresses. Pushing the button on the Homematic interface works fine. Also does invoking a BidCos-RD virtual key via Home Assistant. When I switch to HmIP, nothing happens.

Service homematic.virtualkey with params:

address: HmIP-RCV-1
channel: 11
interface: HMIP
“HMIP” is the interface name from my configuration.yaml.

From the Home Assistant Log:

Logger: homeassistant.components.homematic
Source: components/homematic/init.py:273
Integration: Homematic (documentation, issues)
First occurred: 20:57:41 (11 occurrences)
Last logged: 21:05:38

  • HMIP-RCV-1 not found for service virtualkey!
  • ZENTRALE HMIP not found for service virtualkey!
  • HMIP-RCV-50 not found for service virtualkey!
  • HMIP-RF not found for service virtualkey!

From the Homematic Device list:
Name: Zentrale HmIP
Typenbezeichnung: HmIP-RCV-50
Seriennummer: HmIP-RCV-1

Running the test script only works with the CCU name, not its identifier:

object obj = devices.Get("Zentrale HmIP");
if(obj) {
else {
  WriteLine("not found");

It would be great if someone could help.

Best regards

did some of you solve the problem? I have the same issue.
Thanks and best regards

Nothing has changed in pyhomematic regarding the CCU. It’s still defined as a remote here. So it probably is cause by an update of the CCU.

I also think, it has something to do with the CCU update, as it was working flawlessly before 3.53.26.

Today I installed the 3.55.10 update. But still I can’t reach the buttons. Perhaps one could help me where to start debugging?

1 Like

I tried the same thing (using virtualkey hmip-rcv-1 to address hmip-wgc).
but still got the same message in the homeassistant log:

HMIP-WGC not found for service virtualkey!
HMIP-RCV-1 not found for service virtualkey!
HMIP-RCV-50 not found for service virtualkey!

has someone already solved this issue or is it really related to the CCU version?
i would really appreciate some good news on this topic :slight_smile:

Seems like to be a case-sensitivity problem as described in

I was able to make it work (via custom component) and created a pull-request with the fix