Homematic - Missing support for remote control HmIP-RC8?

Hi guys,

I have integrated Homematic with HomeAssistant via add-on “Homematic CCU” and the appropriate homematic config in configuration.yaml.
On the hardware side, I am using a RaspberryPi 3B+ with HmIP-RFUSB stick.

All devices are working fine except remote control HmIP-RC8. It shows up in the HomeMatic CCU UI, but there are no entities created in HA, unlike for the other devices.

So I am wondering if HmIP-RC8 is actually supported by the integration yet and if yes, what could be the reason what it doesn’t show up in HA?

Thanks for your help.


Just saw that the remote should work based on the code in:

I have just done a factory reset of the remote and added it again to the CCU, but still no success - its not showing up in HA :frowning:

I think I read somewhere that these devices don’t create devices, but that you can trap the events when a button is pressed. Perhaps if you enabled debugging for HomeMatic and tried it, you might get some insight into it.
On the other hand, it could just have been a bad dream!

Hi sota,
thanks for the hint. I have tried to capture all events in HA via Developer / Events / Listen to events and then used * as event name.
I checked all events within the short time while I pressed some buttons on the remote but couldn’t find anything in the log output. Other Homematic events like the ones from a heating are there, so I suppose that means there are no events created by the remote yet.

One thing I noticed is that when pressing buttons on the remote, the LED blinks orange and doesn’t change to green afterwards - probably because nobody is acknowledging the event. Not sure if that is related to my problem or it would still be the case even if the events showed up in HA as nothing reacts on it yet… ?

Strange. I have a HmIP-WRC6 wall mounted switch. Looking at my entities, I don’t see it listed there either. I never noticed before as I only use it from HomeMatic. However, that led me to the link for the post I mentioned:
This gives you a way to work around the problem. Please let me know how you get on.

1 Like

It works! :slight_smile:

Following the instructions on
https://www.home-assistant.io/integrations/homematic#homematickeypress-events-for-homematic-ip-devices did the trick (this page was linked in the post you mentioned). I must have missed that when I looked at this page before some time ago - that again tells me to always read stuff till the end.
Although I don’t really understand why its necessary to create this program (even just temporarily) and why this can’t be automated somehow, I am happy that it finally works.

Many thanks, Pat! :slight_smile:

Great, glad to be of assistance :wink:

I don’t know for sure, but my assumption about this is, that within the HomeMatic ecosystem you typically link remote controls directly to other HomeMatic devices. Hence the CCU doesn’t need to listen for those packets. The CCU only needs to know about these packets if they are used in the programs you can define on the CCU. And it’s this step that also activates those events on the XML-RPC API that Home Assistant is using to communicate with the CCU.
If I’m not mistaken there actually also would be a way to do this automatically. But there might be cases where this actually not the desired behavior. So taking this one manual step seems reasonable.

1 Like

Hi Daniel,

thanks for the explanation - it’s starting to make sense for me now :slight_smile:
Only two more questions:
How come it still works after you delete the program at the end as mentioned in the manual (I haven’t tried it myself yet)?
And does it matter whether you delete it or now actually?

It’s been a while since I had a look at the topic. If I recall correctly, creating the program also creates a direct link between the device and the CCU. Have a look at this for more information about what happens in the background. On the last site of the thread there’s also a reason why this should not be done preemptively.