Homematic Thermostat Lowering and Comfort Temperature

Hi all,

some Homematic thermostats, e.g. the HM-CC-RT-DN, support a “Lowering Mode” and a “Comfort Mode”. Each has a preset temperature. In my case the Lowering Mode has 15°C and Comfort Mode has 20°C. The modes can be easily changed on the thermostat itself.
It is possible to set the mode via “set_dev_val” service, but this is really complicated.
An additional “off” mode might turn the thermostat completely off.

It would be great, if Homeassitant supports this right away inside the Climate Card. Especially now that the slider is gone in the latest releases.

Kind regards

Thanks for mentioning the missing modes. I don’t know why we didn’t include those from the beginning. I’ve created a PR to fix it in the library HASS uses here. Once that got reviewed the changes need to be added to the HASS-side as well. But I guess with HASS 0.41.0 the COMFORT_MODE and LOWERING_MODE will be available.

An extra off-button won’t be implemented. There is no real “off” with these thermostats, only a “below minimal temperature”, which is displayed as off. You get to that point when you turn the target temperature all the way down. Which is rather inconvinient with the new UI, but it’s still possible to achieve. So an extra button won’t be part of the general thermostat-UI. At least I don’t think somebody would implement this.


Since I’ve never used those modes I don’t know what the expected behavior is. However, here’s what I’ve came up with:

  1. Replace thermostats.py from your dependency-folder with the one I’ve linked here.
  2. Replace components/climate/homematic.py of your HASS installation with the one I’ve linked here.

If I didn’t mess up, you should now have the additional modes (if the device supports them). For me selecting them results in the general mode (auto/manual) staying where it is, but setting the target temperature to the one that’s set up for the device. Is that how it should be?

I was on a business trip last week. So sorry for late reply. I will check this weekend, but I guess I need to update to 0.40.2 first, right?


I would just wait until tomorrow. The change is included in 0.41.0, so you’ll get it with the regular update.

Edit: Scratch that. I just saw, that my PR has been merged to the dev-branch, not to the one for the upcoming release.

If you just replace those two files mentioned above, it should also be compatible with older versions. To be safe just make bakups of the files before replacing.

Hey! I just upgraded to 0.40.2, made a backup of the 2 files, replaced them and restarted the server.
I made some few tests via Webinterface against my 3 thermostats (HM-CC-RT-DN). So far it worked like a charm!! :blush:

I will write some scripts and automation tomorrow and will give more feedback!

Thank you, Daniel!! Homeassistant and its community is really, really cool!

1 Like