HomePods and Google mini: free m configured and then went missing

I installed HA in a Python virtual env on a 2013 Mac Pro, and it works like charm. Except for HomePods and Google mini.
At first it discovered them correctly (I have 1 Google mini, 2 HomePods and 2 HomePods mini). I was able to see what was playing and I tried to play radio stations on them. It worked.
However not even a day later for some reason they went missing.
HA can’t seem to find them anymore.
It’s almost as if they have been put in a black list of some sort…

The only thing I did, and frankly I don’t remember if the media devices went missing right after I did it, is that I added a media folder in the configuration.yaml file.

I removed the integration, I restarted HA, rebooted the Mac, rebooted the HomePods.
Nothing helps.

I logged online but couldn’t find exactly the same problem.
Running 2023.12.3

Logs don’t show anything helpful.

Any idea??

Now also my EcoBee became unavailable.
What’s going on?

Is it normal to have such poor reliability??

Ok, leaving this here only in case someone else runs into the same problem: VPN.
My VPN was connecting automatically, affecting service discoverability.
Nothing wrong with HA directly.
All is back to amazing :slight_smile: