Homeseer HS-WD100+ UI Problems/Tried everything

I have an HS-WD200+, HS-WS200+ and 5 HS-WD100+ installed.

They all work flawlessly, paired easily, and I have double/triple taps set up as well as RGB LED control.

My big problem is when I toggle them on/off in the UI, the toggle quickly moves back to the previous setting, then a few (3 or 4) seconds later moves to what it should be. Sometimes it doesn’t move back at all and stays in the incorrect position.

I’ve read all the posts on here about these switches and tried the suggestions but none of them work. Hasn’t someone figured this out? I’ve been dealing with this for half a year and just bought 5 more. Something to do with the refresh rate or instant update feature?


Try this: HomeSeer HS-WD100+ dimmer UI lag (instant status)

I had tried that but it didn’t have any affect. Did you need to restart home assistant after?

Do you mean set that parameter to 10?
I think mine was set to 220 as default.

Nope, I just tried again, setting all of them.

Doing some more testing I’m finding the behavior is completely inconsistent. Sometimes it works correctly and never flip flops, other times it flip flops and then a few seconds later changes to the correct state.
Then other times it flip flops and never goes back (at least within 5 minutes of waiting). It doesn’t matter if I’m turning them On or Off, it happens both directions.
Setting brightness in the UI is also very screwy but I’m less concerned about that.

Clearly there is some inconsistency with home assistant/open z-wave and homeseer’s z-wave protocol because all of my homeseer switches do the same thing.
My double/triple tap and RGB LEDs have worked flawlessly for months, it’s just this last aggravating bug to figure out.

BTW, I added them all as “Add Secure Node”. Would that make a difference?

You need to set parameter 10 to 10 and then click on “set config parameter”
It will take a few seconds, but no reboot necessary

I’ve tried setting parameter 10 to 10 dozens of times across two installs, and every time I do, parameter 10 sets itself to 220 after a few seconds. The lowest I can go without the value changing to something entirely different is 30. Any clues?

Mine is doing the same thing, except I’m changing it to 10 from 220 and it resets to 170.
I can’t get these to work reliably on HA.

1 Like

Got them to stick at 50, made no difference at all.

Yeah I still have this problem. It has absolutely nothing to do with setting any parameters on the device, I think it’s a bug in the open z-wave library that HA uses.
The parameters just control how quickly the lights dim and have nothing to do with the z-wave protocol.
I’m still very confused why no one has figured it out and fixed it yet.

Damn. That sucks, my house is full of them.

1 Like

Am having similar issues. I contacted homeseer support but they couldn’t be bothered to help.
Super interested in any ideas / workarounds. It would be pretty expensive and very time consuming to replace all the switches :frowning:

From what I remember, looking into this over a year ago originally, it comes down to Home Assistant updating the version of “openzwave” they are using. I’ve just been patiently waiting for an updated to magically fix the issue. More information here, it sounds like they are still not ready to update:

More info here also:

1 Like

Any update on this issue? I’m having the same problem with Zwave-JS.

I thought I would chime in as well that this issue continues to annoy me. At this point I may just replace those switches since I’m only dealing with four. I regret getting them.