HomeSeer SmartStick G8 Installation/Configuration

I am new to Home Assistant but have been using a HomeSeer system (Raspberry Pi box, not a USB stick) for several years. Of course, rather than using one of the plug and play HA options, I decided to setup my own HA system from the bottom up. I am using the following equipment/software:

Mini PC (AMD Ryzen 9, 32 GB DDR5, 1 TB SSD, 4X USB3.2, 2X USB4, 2X HDMI 2.1, WiFi 6E)
Windows 11
VMware Workstation Pro 17.0 for Personal Use (Windows)
HomeSeer 800 Series SmartStick G8 LR
Z-Wave JS UI (Z-Wave-JS not installed.)

I have HA installed and working on the VMware virtual machine. I’ve been able to access/control my newer Philips Hue and Leviton devices in HA without any issues. Our MyQ garage door openers are a project for another day. However, my “legacy” devices are all Z-Wave Plus from the HomeSeer system.

I am currently stuck on getting Z-Wave JS UI properly configured, specifically the serial port designation. I’ve seen entries searching this forum such as “tcp://192.168.10.234:10004”. How do you determine the proper IP address/port to enter in this field (none of the pulldown options worked)? Does it need to be the IP address of my VM? I’ve looked in the Windows Device Manager to no avail and even tried running “netstat -ano” from a Windows Command Prompt (returned a ton of TCP entries, so many it didn’t really help).

Thank you in advance for any advice/tips.

That HomeSeer stick is usb - not network connected. So because you decided to do a virtual install you need to make sure it’s first seen by your hypervisor (usb com port most likely) THEN passed through to the correct VM. At which point you would look under

Settings > System > Hardware > all hardware to find the path to the stick.

1 Like

Thanks, Nathan.

I had already added the USB Controller to the VM. But after reading your post, I looked into this issue further on the VMware website and found that the missing step was going into VM Workstation Pro, to the VM menu > Removable Devices > USB Device > Connect (Disconnect from Host).

Supposedly, when you plug a USB device into a Windows host system, Workstation Pro prompts you to select a machine to connect the device to. However, in my case, I had attached the HomeSeer SmartStick before I installed VMware. So, I had to complete that last step manually. And of course, the displayed name of the “removable device” gave no hint that it was the SmartStick.

I didn’t get a chance to test anything out last night, but I was able to find the designation for the SmartStick by following your directions. In fact, that name showed up in as an option in the pulldown menu. Now that the SmartStick is showing up, it’s on to trying to get my Z-Wave devices moved over to HA.

As for the USB Controller device in my VM, it is currently configured (by default) for compatibility with USB2.0. Would it be to my advantage or disadvantage to change that setting to USB3.1?

1 Like

No advantage to USB3. In fact in real iron we intentionally avoid USB3 connections because the 3ghz interference drives ZWave and Zigbee sticks nuts. (the reason why you see so many recommendations for short usb extention cables)

I just wanted to post a follow up in this thread for anyone else who may find this information useful.

As noted above, I was previously able to get Z-Wave JS UI to recognize my SmartStick (Node 1). However, at that point, I could not get the system into inclusion mode in order to add new devices to HA.

My confusion had to do with Z-Wave JS UI vs Z-Wave JS. I had read several posts about how you cannot use both of these add-ons at the same time. But whenever I tried to install the Z-Wave JS integration, it wasn’t installing properly and was also installing Z-Wave JS as an add-on which I did not want. After closer inspection, I discovered that when installing the Z-Wave JS integration, you must uncheck “Use the Z-Wave JS Supervisor add-on” box. It wasn’t clear to me initially that Z-Wave JS Supervisor add-on was the same thing as the Z-Wave JS add-on.

Since I got the integration installed, I’ve had no problems adding any of my existing Z-Wave devices.