Homme assistant Yellow Installation issue

It would be interesting if people who successfully NVME boot HAOS 9.2 on yellow with an NVME indicate which SSD is used and what type of CM4 (lite or not).

I now have a new SSD: SAMSUNG 980. It boots and I installed HAOS without any problems on my CM4 lite. I am very happy.
I’ve spent a lot of time with my Crucial P2 CT250P2SSD8, and I’ve wasted a few people’s time too. However, this lost time is not lost for future users who now know that there is currently a risk of incompatibility with the Crucial P2.
Thank you very much to everyone who helped me with this problem and gradually led me to suspect a problem with this SSD.

2 Likes

IMO, if user has to change standard working SSD to another brand/model SSD is bad solution. It works today, how about after next update? After all, Samsung, SKHynix, Crucial etc. are all supposed to be standard compliant nvme-drives. It’s PITA, if you can’t trust updates will work, or if update requires manual installation, at worst case, using separate computer.

Had same problem. Looking at switch, saw that pi-cm4 was listed on that port. I’d reused an WD 750 SE Black that I’d been doing some testing with and that was my issue. ssh’d to that IP address (fortunately login was pi/raspberry still) and then did a “sudo su” then I simply ran “parted” and “print all” to find the partition numbers, then “rm 1” and “rm 2” Ignoring the warnings. Then pulled the power plug, put the USB with the install files in, and plugged it and the Ethernet back in, and it did the install properly.

Was getting worried after reading through this thread, glad it was simple as deleting the NVME partitions.

1 Like

Home assistant yellow POE + CM4 Lite Tried all of the above.

Cloned a USB drive with all the boot partitions to the NVMe which seemed to work?
The leds no longer stayed on Red / Green sadly after a few minutes the result was the same.

Tried rpiboot , no avail

Was using a PNY CS1030 250GB,Ordered Samsung 970 EVO Plus MZ-V7S500BW waiting to arrive.

They should really ship these devices with a list of guaranteed working NVMe drives!
All of this wasted time could have been avoided.

Please adjust your NVMe support page

  • "Yellow has an M.2 M-Key connector which technically supports any NVMe SSD "

Enforce people to buy the working ones instead!

1 Like

I have a Yellow POE + CM4 Lite. Used a Samsung 960 PRO NVMe, installed and worked no issues. However, I didn’t want to use such a large and expensive drive on my yellow. Purchased a “TeamGroup” 256GB NVMe. HASSOS installer worked fine, system rebooted and no web page. Connected to USB console, and in supervisor logs, get " Home Assistant has crashed!". Tried to do a supervisor repair and re-install of the Core, and no good. Always get’s a crash message. Other then that, system boots, no errors on DMESG or kernel logs. Ordered a Crucial P3 to try, if that doesn’t work, will go to another Samsung EVO drive.

UPDATE: The Crucial P3 500GB NVMe works fine as well as the Samsung 960 PRO 1TB NVMe

Do not purchase the “Teamgroup MP33 NVMe” 256GB – at $19 it would have been a steal if it worked!

I cannot seem to find any common demonator between these SSD’s to determine what works, or what doesn’t.

2 Likes

hi all,

hope someone can help, I’m trying to setup a HA yellow with a CM4 2Gb LITE, and a EVO 970 plus 1Tb,
but al I get a is a blinking yellow LED, It gets a IP, and I can ping the ip, the SSD in brand new and untouched, if i remove the SSD from yellow and install it in a NVME case I can see it on my mac and it has no partitions etc.

Whats going on ??

Thanks
Andrew

I had the opisite to what issue you seem to have it took me 9 months to figure some how to reset due to no yellow light at all.

Then had to make a image file which again is not stright forward to do I ended up with guessing! Adn once flashed managed to get it to load up. But im still not sure if mine is working yet as its taken over a hour to do a restore from my previose Home Assistant.

So Im not goign to be no help to you on this! At moment!

thanks, I got it sussed, it was down to the yellow defaulting to IPv6 and not IPv4, my yellow had an ip6 address but no dns, and thus it was just sitting there, I had to setup on a router that did not have any IPv6 support at all.

I’ve just managed to get transfered over to the Yellow, but needing help now on why Im not getting no notifications sent from sensors, and also a Bluetooth issues so not clues on whats up any help be great!

Sounds a complex fix glad you figured it out, I might have the same issues as no notifications being sent and no bluetooth,. though I have no clue where bluetooth is coming from? will it be from the Yellow to the router or to mobile?

try disabling g IPv6 in the network setting in HA, If your CM4 module has bluetooth, it will search for any bluetooth client and try to add it to HA, it could be anything.

I figured it was because I had forgot to transfer the Sonoff Dongle from the Raspberry Pi 3b to the Yellow and also the Bluetooth one too. As soon as I did this all up and working!

The backups also I think only take arond 5 mins and there is a re fresh bug so the user does not know when its restored your backups!

So I left it over night come back to it and it was still backing up , so tuened it off and back on and it had restored.

But with me thinking it had missed things I did another fresh backup to make sure.

All up and running now! No IPv6 issues on looking in the network setting In HA I have them both set to Automatic.

1 Like