Honeywell Thermostat install

Looking for help finding out how to integrate my Honeywell total comfort thermostat in to my system. Looked in the online docs but could not make senses of them I’m new with very little coding background.
Thx
D

I’ve got three Honeywell WiFi thermostats working fine with HA.

First of all, does yours work with Honeywell’s Total Connect Comfort app? That’s the first thing you need to set up.

The HA integration doesn’t communicate with the thermostat, only with the Honeywell server. There is no (known) way to directly access the thermostat locally.

After that it’s just a matter of adding a few lines to the climate: section of your configuration.yaml file. If you don’t have a climate: section, create it.

This configuration file isn’t really coding, it’s just a way to store settings, although the format is very finicky. Make sure you use a text editor and use spacing (not tabs) exactly like the example in this documentation:

You didn’t really ask a specific question, so I’m not sure if I’ve helped you at all, or just insulted your intelligence. If the latter, sorry. I figured I’d start at the beginning, and even if this doesn’t help you, it might help someone else.

I have the info in my config file, but what card do I use? I tried the thermostat card but comes up blank.

What name did you give your thermostat in the Honeywell app or web site?

That’s the name which should appear under Configuration / Entities in HA.

You should be able to click on it, then select the “settings” icon in the upper right corner to see your thermostat settings.

If you don’t see the entity, then either you haven’t restarted HA since the config file change, or the settings in the config file aren’t correct, or for some other reason HA can’t communicate with the Honeywell server. The log in Configuration / Logs should tell you why.

I have the card setup as a webpage card. The web site how’s up fine. I tried to in but get an error that cookies must be enabled?

I just placed the WEB page link. I don’t see the entity listed so it sounds like I need the API needs to be listed in the Config file? How do I get that API I looked around the Honeywell page after logging in did not see a place get it? Just think I have this all wrong from the start, sorry for being so slow.

I’m just glad to be able to help; usually these threads get beyond my HA experience level too quickly!

First off, review the documentation at the link in my post #2, above. I know there isn’t much there, but that’s really all there is to it. You just need to add platform Honeywell to the climate: section of your configuration.yaml, then add your own username and password (the one that you use on the Honeywell web site) as shown. Of course, you want to run Check Configuration under Configuration / Server Controls to be sure there’s no syntax error.

The rest should be automatic once you’ve restarted HA. It knows how to reach out the the Honeywell servers using their API and the credentials you supplied in configuration.yaml.

If there’s any problem, it should show up in the log (Configuration / Logs). I’ve found it’s a good practice to always check this right after any restart.

If there’s no problem, you should be able to follow my second post to verify you’re receiving data.

This what I have in my config file:

climate:

Example configuration.yaml entry

  • platform: honeywell
    username: real name
    password: real PW

Hear is my Error Log:

Log Details (ERROR)

Logger: homeassistant.components.honeywell.climate
Source: components/honeywell/climate.py:118
Integration: honeywell (documentation, issues)
First occurred: October 21, 2020, 4:45:21 PM (1 occurrences)
Last logged: October 21, 2020, 4:45:21 PM

Failed to initialize the Honeywell client: Check your configuration (username, password), or maybe you have exceeded the API rate limit?

I do not see the Honeywell Thermostat as an Entity or an integration.

I’m at a losses.

Here’s my configuration.yaml:

climate:
  platform: honeywell
  username: !secret honeywell_user
  password: !secret honeywell_pass
  #region: us
  scan_interval: 600

I use the Simple Thermostat card to display it : https://github.com/nervetattoo/simple-thermostat/

image

        - type: custom:simple-thermostat
          entity: climate.6900_upstairs
          name: Home - Upstairs
          step_size: 1
          icon:
            idle:
            cooling: mdi:air-conditioner
            heating: mdi:fire
          hide:
            state: true
          sensors:
            - entity: climate.upstairs
              name: HVAC Mode
            - entity: climate.upstairs
              name: Away is
              attribute: preset_mode
            - entity: climate.upstairs
              name: Fan mode
              attribute: fan_mode
            - entity: sensor.upstairs_last_changed  ## Custom Sensor
              name: Changed
#            - entity: climate.upstairs
#              name: Fan is
#              attribute: fan_action
          control:
            - preset: false
            - hvac: false

This is good. The error message is pretty clear. HA sees your config entry for the Honeywell platform and tries to connet. The connection fails. The message even gives you three likely reasons why it failed. You’re lucky; not all HA log entries are this informative!

Taking the last one first, I doubt you’re being rate limited. The fact that you only got one message suggests HA didn’t try more than once, so it’s unlikely to have hit the limit. Of course, if you have the Honeywell app or web page open, and keep refreshing, that could impact HA’s ability to use the API, but I assume that’s not happening.

Most likely either the ID/Password is wrong, or the syntax defining them in the configuration.yaml is wrong.

Go to the Honeywell web site and try to connect using those credentials:
https://www.mytotalconnectcomfort.com/portal

If that works, triple-check the ID and password in the config file. Make sure any special characters are exactly correct (apostrophes and quotes come in various different styles.) Check upper/lower case. Make sure you use spaces and not tabs to indent those lines in config. If necessary, copy and paste so you’re positive you’re using the same values. Save the config file, validate it in HA, then restart.

When building the card in “Love Lace” I get error message “No card type configuration” . I’m using a manual card type and have the “simple-thermostat” file in the www directory?

Personally I switched to HACS for ease of installation of these custom cards / resources. https://hacs.xyz/

Once I installed the simple thermostat thru there it needs added as a resource in your ui-lovelace.yaml:

resources:
  - url: /hacsfiles/simple-thermostat/simple-thermostat.js
    type: module

I have HACS installed but did not see the Integration?

Keep looking? Mine’s under ‘Frontend’

image

now tht I have installed via HACS and update the LovLace.YAML file, Do I use a Custom card or will there be a card just for that “Simple thermostat”?

The exact config from my ui-lovelace.yaml is posted above, along with a screenshot of how I display my zone(s). Would suggest using this as well as the custom-card’s documentation to configure exactly how you’d like it to appear

when I setup a custom card I et this:

Did you ever solve the problem which caused the error log entry you posted, above?

That would be necessary before choosing which card to use in Lovelace.

Yes, I have the standard thermostat card working.

Good, glad you got past that initial problem!

For future readers, maybe you’d like to elaborate as to what fixed it, maybe even mark some post as the solution.

Also, in the future, it’s best to start a new thread when you move on to a new question.