How can I cast my Amcrest camera to my Android TV or Nest Hub Max?

When I tell google to cast the camera, I get the screen with the heart Nabu Casa instead of the stream…
-My home assistant is behind DuckDNS and NGINX. I have Adguard running in HA with a custom filtering rule which redirects local attempts to my duckdns server to the local HA IP address.
-I manually integrated google assistant in HA and exposed the camera entities to Google. The icons for the cameras show up in the Google App.
-I authenticated with http://cast.home-assistant.io/

Hey, having the same issue. Did you ever resolve this?

No, I couldn’t find any assistance with this. If you are able to get this to work please report back! I’m surprised this isn’t something better documented

I have just tried something I found. Setting the internal_url to external_url seems to fix the issue (working for me now). See thread:

Casting security camera’s to google not longer working - Configuration - Home Assistant Community (home-assistant.io)

That’s great to hear! Does this not cause problems accessing home assistant at all? What is your set-up? I run NGINX and I did something like that before and lost all access to HASS so I am afraid to try it again.

Only had it on since this morning, but no issues so far (tested from internal and external).

Running HA in docker with NGINX reverse proxy. Though I use my own domain and cloudflare rather than duckdns.

Good to know. I’ll back up my VM and give it a spin. Is it necessary to indicate the port 8123 though?

I don’t, NGINX deals with port stuff for me. All my requests are through HTTPS

hm, same. Tried setting external_url and internal_url through configuration.yaml and through the UI. No port since I use NGINX. Even changed DNS to 1.1.1.1 to eliminate Adguard from equation. Still no dice. How do you have your amcrest cameras configured? My configuration is as follows:

amcrest:
  - host: CENSORED
    username: CENSORED
    password: CENSORED
    name: "CENSORED"  
    resolution: high
    stream_source: rtsp
    binary_sensors:
    - motion_detected
    - online 

Nevermind. It just took a few minutes and is working now. Thanks for your help!

So interestingly it works for my tv but not my nest hub max!