How can I get a esphome bin file on a new esp32 board without a micro isb port

Hellow, i’ve bought a esp32 4relay board ac/dc.
There is no micro usb port on it.
How can I connect it with mij pc on windows, so I can first flash it, and after it use OTA?

to program it you’ll need something like

f.e. connected to an esp01:
(Check this link for more options flashing esp-01’s)


Thanks for the answer,
I’m using this Serial adapter:
And I use this board: ESP32_DevKit_C_V4_Pinout.pdf (
I’m powering the board by the micro usb port.

When I connect the Rx to the Tx, and the Tx to the Rx, I can view logs of the Esp32 board.
But what have I got to do for downloading a new program?
When I do it with Web-Esphome, he says ’ failed to connect’
And with Esphome flasher:
I can read the logs.
but when I want to flash I get : Unexpected error: could not open port com6: PermissionError(13, ‘Access denied.’, None, 5)

I also have that error sometimes, i usually solve it by downgrading the drivers :thinking:

do you also use ESPhome flasher?

Yes, i do (on W10)

But I have the same issue when trying to install. y means of the web-serial through the esphome addon :thinking:

and also with this converter?

not that one, the one from my picture.

But, since they are both CH34x based, a driver downgrade should fix it:

I downloaded an older version 3.5 from 2019-03-18 with help of
After installtion, the problem was fixed!

And for some reason W10 keeps on updating the driver regularly, even without asking…
So i just store the old drivers, and downgrade whenever the fault re-appears :wink:

The 3.5 driver is also for your CH340G

I finally made it.
I make the connection with the following adapter: ESP-PROG - Open Source Hardware Board (

Good to hear you fixed it; that was indeed another option…

The permission issue is related to the driver of the CH340G, and has on itself nothing to do with esphome or espflasher :wink:

And, if i may ask, is your ‘solution’ really related to the original question? :thinking:
It basically doesn’t matter what kind of ttl-serial usb-connector you use, the point is that you need to use one.
And I am even pretty sure you CH340G will also work if you downgrade your drivers (and that would have saved you €3,95 + shipping too)

So shouldn’t the solution be the 1st reply on your post ??

Maybe, but i’m happy it works now :blush: