How can I get rid of "New devices discovered" notifications?

So I’m getting a lot of these “new devices discovered” notifications in Home Assistant, I have no idea why because there are no new devices. They keep coming again and again which is incredibly annoying.

I found an automation relying on the entity “persistent_notification.config_entry_discovery”. It is not in my list of entitites and when I use this code, HA doesn’t recognize it as a trigger:

alias: Remove new devices notification
description: ""
trigger:
  - platform: state
    entity_id: persistent_notification.config_entry_discovery
    to: notifying
  - platform: homeassistant
    event: start
condition: []
action:
  - service: persistent_notification.dismiss
    data:
      notification_id: config_entry_discovery

This would now only work for me on HA starting but it would be great to have the system dismissing this message every time it appears (if I can’t tell HA to not even send it). Any ideas on how to solve this?

So when you click on the “Check it out” link there are no newly discovered devices in Devices & Services?

No, it takes me to my integrations dashboard. I didn’t install any integrations recently.

1 Like

Top right in the integrations dashboard (aka the Devices & Services panel) there should be a new card showing which device was discovered. It will have the option to either install it or ignore it. If you select “ignore” then it should not notify you about this device again.

1 Like

Oh, you’re right. The term “devices” was misleading, I didn’t think it was about integrations. There are some integrations I didn’t configure yet but wanted to do this at a later point. I will then click on “Ignore”.

I was convinced it would be some kind of mistake and reinterpreting a device as new that was already there for ages. The Alexa app does that sometimes. Hope that solves it but I guess it does, thank you!

2 Likes

If at a later date you do want to install them, there’s a filter button top right:

Untitled

1 Like

Oh good, otherwise I would have just screenshotted that but that’s more convenient. :+1: