How can I set wakeup interval for Aeotec WallMote?

I am trying to get the Aeotec to report current battery status.

The Node Information shows wake_up_interval: 0 which means it is disabled.
I want to set it to 1.

There is a “SET WAKEUP” selection in the node config but it doesn’t seem to do anything. I wake the wallmote and press the button but nothing changes in the information panel. It remains 1. I am not sure if the “SET WAKEUP” requires you enter the value desired I have tried without a value and with a value of 1.

Are you sure you need to set the wake up interval to get the battery status? I think the battery level is reported automatically under the entity. If it’s not there then I think you need to change the “report type to send” value.

i have several aeotec devices (but no wallmote) and i’ve never had to set that to get the battery level.

It is reported and populates correctly on boot but it doesn’t seem to update. It was 100 for several days. After I restarted HA it updated to 64%.

So HA only seems to issue a battery_get on boot but never after that.

I don’t know if I would trust those numbers. Either there is something wrong with the device or the battery. I’ve had a number of z wave devices for going on 10 months now and the battery levels are still in the 90’s. I would be surprised if your battery levels dropped from 100% to 64% in a few days.

Have you tried to restart HA again and see what the battery reads after that? Something definitely doesn’t sound quite right. But again I don’t have a wallmote so that battery usage could be normal I guess. If so that would suck to have to change the batteries every couple of weeks.

And I wouldn’t think that they would design the device to make you have to take some action to get a battery reading from it, either. It should do it automatically but I don’t know what the reporting interval for that would be.

I know that doesn’t really help answer your question per se but it’s something to keep in mind.

So your saying HA isn’t handling battery_level correctly? These devices and battery levels work fine on my SmartThings system.

My wallmote was reading 100% when I first set up. That was correct because I had just charged it. But it never dropped for over a week so I knew it wasn’t working. 100 is the default so I assumed it just didn’t work. But then I was working on my configuration and when I restarted it changed to 64% which seems correct for the time frame. I have restarted several times today (debugging automations that are not working) and it stays at 64% so I think the startup reading is correct.

I suspect it just never updates. Making it pretty much useless unless I configure HA to reboot every day or something.

If you read the zwave guides they do in fact respond to a COMMAND_BATTERY_GET_V1 call. That is typical of zwave devices. On the next wake it will report the requested status. I wrote my device handler on SmartThings working with the techs at Aeotec so I am pretty well versed in how the device works. My problem is I don’t know how to program HA at low enough level. I am surprised you can’t make ZWAVE command calls in HA. Many devices have calls to check the firmware, check manufacture info, etc. But you need to be able to send the command sets. Many devices have configuration that needs to be set in non-standard ways also. Like the ZXT-120 which I really want to get working.

So far I have 3 out of 5 devices that I have set up on my HA system where I can’t work correctly with them.

  • ZXT-120 - broken unless you hack Open Zwave
  • GD00Z-4 - Garage controller, also need to hack Open Zwave to fix this
  • Aeotec Wallmote - have to hack open zwave config, and even after that the device is crippled and has weird sensors that make no sense. For example it has a switch which does nothing. If you manually turn it on it just flips back to off. It seems to have no purpose at all.

Sorry, it’s way over my head now.

Good luck!

1 Like

Haha, me too.

1 Like

Comment found in the Open-Zwave code. They mention that you can issue a BATTERY_GET to request a BATTERY_REPORT…now just have to figure out how you do that.

        <!-- COMMAND_CLASS_BATTERY. -->
        <CommandClass id="128" name="COMMAND_CLASS_BATTERY">
                <Value type="byte" genre="user" index="0" label="Battery Check" units="%" min="20" max="100" value="">
                                The users can also inquire the battery status of the unit by sending
                                BATTERY_GET command via Z-Wave Controller. Once the unit receives the
                                command, it will return BATTERY_REPORT command. The unit will send
                                Battery_Level = 255 (0xFF) command to the Z-Wave Controller to inform that
                                the unit is in low battery status.

Hate to jump onto such a dated thread but running into this same issue myself. Was there any resolution?

I never got it working. It still gets a current value when the machine is booted but then never updates. Not sure if it is a bug in the remote or what. You might want to reach out to Aeotec support if you really care they are pretty good and have helped me in the past with other issues.

I never chased this down because I discovered it is not really needed. The remote turns yellow when it needs a charge and lasts quite a while in the yellow state. It’s hard to miss so when I see it’s yellow I simply charge it overnight and put it back up on the wall.

So unless you need to monitor from a remote location because you are not physically present where the remote is deployed I think you will find you can do fine without the status from HA.

1 Like