How close together is too close?

I am migrating from a Vera to HA and am finding some similar quirks to what I seemed to be running into with Vera… namely, devices in HA become “unavailable” for unknown reasons and I’m wondering if it’s because it is in too close of proximity to another device or simply too many devices within a small area.

Examples:

  • I have multiple items in a cabinet that make up my home lab. In the past, I had each device (multiple NUC’s, a couple of desktops, a NAS, etc.) all connected through Aeotec Smart Switch 6 plugs so that I could monitor power draw as well as have routines to handle graceful power down and power up of the environment. Sometimes, certain plugs just “disappear” from the network for extended periods of time.

  • I have two coffee makers set up at a coffee station. One is a drip maker and the other is single brew with pods. Since they’re both plugged into the same circuit electrically, I only want one to be able to be in operation at a time. I use automations to detect when the drip maker is under heavy draw and power off the single brew maker then turn the single brew back on when power consumption on the drip maker drops. The plug for the single brew has become unavailable and isn’t returning. Is it because they’re plugged in right next to each other?

The network and overall environment with the Vera was long-standing and relatively stable when this started happening. The network and setup for HA is still being built out.

Maybe… But. Generally speaking as you describe. No.

Similar issues as you describe usually exhibit themselves as RF interference. But to know if you actually have this kind of problem, you’d need to analyze each type of device as classified by the kind of radio they use to communicate.

WiFi, thread, Bluetooth, zigbee, ZWave, 433 etc.

Some of the ones on the list conflict with each other, some are particularly well behaved, some… Aren’t. And some depends on user config.

You can pay for an expensive rf survey (or know someone with the gear) to be sure. But you can make some assumptions in current tech and tackle those common problems first.

Make sure you know what radios your stuff use. Understand the uniqueness of those radios.

For instance for Zigbee, (and included here because number one of the interference problems ive seen) know it’s on the 2.5 Ghz unregulated band and very low power therefore bends like a leaf to practically any RF source in the 2.5-3 Ghz range.

So that means When in proximity of 2.5ghz wifi on certain frequency, old wireless phones, microwaves, USB3 - particularly HDDs/SSDs you might have issues with some Zigbee devices. That said,

A lot of the devices you mentioned (Aeotec except some of the new SmartThings designs) are ZWave. ZWave devices are pretty well behaved and don’t live in the same band so aren’t susceptible to the interference above (except USB3 hdds but that’s a special condition). For ZWave instead you usually have signal strength issues… Powered devices repeat for each other but if you recently came off a manufacturers hub like Vera, Wink or SmartThings, you may find your antennas for those hubs were all generally more powerful than your typical USB stick. (When I moved from SmartThings to an Aeotec stick, my effective signal distance for my first hop dropped by 20’)

So to answer your original question. It depends. On a million questions. :wink:

1 Like

Thanks.

I’m all ZWave for my HA stuff, using a NUC w/ an Aeotec USB stick. And, actually, the USB stick seems to actually have a stronger radio than either of the Vera devices that I own have ever demonstrated.

I have powered devices in the mesh for repeating / mesh purposes, but I’m not 100% convinced that it’s working as expected with those.

I’m going to keep experimenting as one of the issues I’m currently struggling with is getting the SS6 devices included using S2 (which they support). My SS7 was no issue, but both SS6 devices I’m working with so far are giving me problems. I’ve determined that the firmware is older and have reached out to Aeotec… waiting on a reply.

SS6 doesn’t support S2, so that’s probably your issue. Only S0, which is no good. Where’d you see that it supports S2?

1 Like

Are you using the builtin Zwave_JS or the ZWave_JS UI Addon? The latter (JSUI) recently updated the tools - specifically the maps and ability to adjust routing. Technically you can get all the same info from Zwave_JS but the new tooling makes it almost a necessary change if your system can do it (especially if you’re having issues)

And Fresh beat me to the SS6 and S2. On that - avoid joining s0 unless ABSOLUTELY necessary like in which cases the device doesn’t work unless at the correct security level like a lock.

One thing on usb z-wave stick. It you run it on a USB extension cable you can get away from interference from the computer(s). I am in a rack and had to move the z-wave usb stick away from the back of the rack to get reliable communication. I have the 5 series z-wave stick and it is in my basement. I can reach to my mailbox which is 70 feet away through 3 walls, a floor and garage door.

I hope this helps.

1 Like

I didn’t… that was an error in terms on my part. It supports S0, but it won’t include that way either. Only unsecured.

I’m not using the JSUI… Just the built in JS. I have both installed but JSUI is in a stopped state. I recall there being a reason I did it this way, but I don’t remember what that was.

Interestingly, if I switch on JSUI, it isn’t able to determine the vendor of my Aeotec Smart Switches while JS picks it up fine.

Thanks… My NUC that’s running HA is actually in my home office, well away from the cabinet / rack where most of the computer gear is. There are a couple of other devices in here, but not a lot. Additionally, I’m really just get started with the HA system over the last few days. Prior, I was 100% Vera and it was also located away from everything else.

You have to explicitly choose “S0” or “Legacy Security” when including the device with S0, it won’t be done by default. But you don’t want S0 for a switch, in most cases it will harm your network performance. See item 6 at https://zwave-js.github.io/node-zwave-js/#/troubleshooting/network-health?id=optimizing-the-reporting-configuration.

You can’t run both add-ons at the same time. https://www.home-assistant.io/integrations/zwave_js/#can-i-switch-between-the-official-z-wave-js-add-on-and-the-z-wave-js-ui-add-on

If you simply turn off the official add-on, the integration will turn it back on. You have to reconfigure the integration to not use the Supervisor, as mentioned in those docs.

With regard to z-wave instability I had tons of problems with devices included with S0 security on two different hubs. I decided to switch to unsecure inclusion and never looked back. All problems gone. If you’re not using z-wave locks or things like that, unsecure should be fine.

S0 security uses way more bandwidth and is thus way more susceptible to interference. Also it is quite heavy on the resources, making it unreliable in many circumstances. S2 security is way more lightweight, so that is a better option of you need the extra protection. But if it is simple switches, I’d stick to unsecure.

Also, if you intend to use associations (direct links between devices) be aware that associated devices need to be on the same security level. As not all devices support S2 yet, this may be another reason th stick to unsecure.

1 Like

I have tried choosing Basic Security when pairing, it doesn’t work and ends up without security.

I’m not running both at the same time. As mentioned, the JSUI is stopped.