How do I add an IKEA Shortcut Button to Phoscon/DeConz?


I have HA installed on a Raspberry Pi 4, with a ConBee II installed with the DeConz integration. Phoscon (and DeConz?) is on version 2.09.03 / 23/12/2020. I have a few Aqara thermometers, an IKEA light and a couple of IKEA On/Off buttons connected, and they all work fine. Yesterday I bought an IKEA Shortcut Button, but could not get it connected immediately. After looking around, it seems like support for the IKEA Shortcut button was added to Phoscon app with beta version 2.9.0 (2020-12-24). Is there some way I can get on the beta version of DeConz with the HA integration?

I also found that some people had better luck with connecting it to ZHA. I have never tried ZHA, but figured I could try it. That did not work at all, because when I try to add the Zigbee Home Automation integration, it first asks for “serial port for Zigbee radio”. When I choose my ConBee II stick in the list (connected on /dev/ttyACM0) and click Submit, it spins for about 20 seconds, and then asks me to specify my Radio Type (I choose DeConz), and then a Serial device path (I enter the pretyped “/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DEXXXXXXX-xxxx”). After that, I immediately get an “Failed to connect” error. Am I doing something wrong here?

And lastly I have noticed that, while Phoscon doesn’t seem to recognize the Shortcut Button, in the DeConz app I can actually see it. And while the other entities have nice names (and actually report temperature or a click), the Shortcut Button is named 0x2008, and nothing happens in the Developer Tools when I listen to the deconz_event. Is it already connected, and am I just missing a last step?

1 Like

same. Cant connect it via Phoscon

Same problem here:
I’ve purchased the Ikea button, but I cannot add it to my Pi3b+ running deCONZ\Phoscon Ubuntu image.
The button does not appear in Phoscon when adding as Switch\Other or any other device pairing method. In deCONZ (graphic user interface over VNC) there is a device showing only the network address and device address. I am unable to change the name of the device.
I’ve also connected node-red to deCONZ, pressing the button does not generate a message whereas other devices (ikea round multi-button, aqara cube) do.

ConBee USB firmware: latest
PhosCon version : 2.07.01 / 08/12/2020 (stable)
Also tried the latest beta version, the button is still not recognized as a device in PhosCon nor does it send any event data. I even tried ZHA Zigbee with a direct connection to the USB device but while a button device is recognized, there are no entities with the device to use in HA.

Hope anyone can help here…

Same situation for me. I can connect to it via the Phoscon beta web app ([hass_ip]:[port]), but I can’t assign it to any lights or groups.

Moreover, in home assistant I can see the device TRÅDFRI shortcut button, but it has only this entity: TRÅDFRI shortcut button Battery Level.

I’m running deconz 6.7.2 as a home assistant addon with the latest phoscon version.

I used this blueprint to control lights and other devices with the shortcut button. Works beautifully. :slight_smile: deCONZ - Ikea Tradfri Shortcut Button


I have the same issue but raspberry Pi 3+ conbee II phoscon version 2.13.04 / 18/12/2021 firmware 26660700

I can add the shortcut button as a generic button and on developer tools I can only find battery level
Clearly no integration works, even using the mentioned blueprint
I cannot figure what is wrong