How do I change the update interval on the RESTful Sensor component?

I’ve read the docs here:

And it doesn’t say how to adjust the update interval, is it fixed? Or is it adjustable but undocumented?


1 Like

Try if this works:


Thanks very much, I didn’t see that in the docs, I’ve added scan_interval: 60 to my yaml file and it seems to be working as intended.

Should I be concerned about this part? Will it stop working in future releases?

These options are being phased out and are only available for single platform integrations.

I’m confused about this too.

Does that mean I shouldn’t use scan_interval?

Was there an answer on this?

Trying to make some sensors that poll online public website APIs and need to ensure I’m polling at an appropriate interval – fast enough to do what I want but slow enough to not blacklist my IP for abuse. This seems critical to have a way to adjust a poll interval for APIs.


Edit: Disregard seems like it may have come good after a reboot at some point…?