How do I enable my HA to connect using Wifi?

My HA works great with wired LAN. However I now temporary need to bring my HA with me to my garage to keep it close to some z wave in wall switches that I am not able to reach with direct zwave from where my HA PC is located currently.

The PC has a wifi adapter so my idea was to unplug it from where it is now. Move it to the garage, power it up and let it work over Wifi temporary just to pair my zwave devices with close proximity to my zwave controller and then bring it back and run it over wired LAN again.

But all guides I find online is about configuring Raspberry Pi wifi prior to setup.
My machine is already up and running and I just want to enable Wifi and thats it.

So I think I have found the right way:

  1. Format a USB with FAT32 and name it to CONFIG
  2. Create folder “network”
  3. Create a file called “my_network” (no file endings) and make sure it has LF line endings with below content:

# Uncomment below if your SSID is not broadcasted



  1. Put the USB in my HA OS machine and restart it.
  2. HA will now load the manual network added and my machine should now have Wifi.

Some questions:

  1. Is this the correct procedure?
  2. Will this disable my wired LAN at the same time? Or will the wired LAN always be prioritized if connected (like a regular machine) ?

So I tested but nothing changed… Still running off my wired LAN so I obviously I did something wrong here.

Any help would be appreciated!

Do you have the possibility of installing a z-wave node between the garage and pc so you can use it to hop to the garage? I also had to use a usb extension cable on my server to get the z-wave controller in the open and away from the rack and servers. This solved a lot of my distance issues. I only have 2 devices that don’t talk directly to the controller after this. One is outside on my mailbox. My servers are in the basement and I can talk to my garage ~50 feet away through 4 walls.

The other option is to get a patch cable that is long enough for you to stay plugged in and move the computer closer.

1 Like

Can’t you do it from the supervisor panel ?


I think you need to unplug your LAN wire for the wifi port to take over.

1 Like

I don’t have those options there…

Thanks everyone for responding!

The solution turned out like this… I found a USB extension cable that allowed the Zwave USB controller to get a bit of distance from the network cabinet as it is a bit crowded in there:

So after doing that all the zwave became very fast in the house! :slight_smile:

Still not figured out that wifi issue though. But I guess there’s no reason for that right now. Tons of animations and scripts to migrate from Homey :smiley:

1 Like