How do I get rid of this switch toggle?

I created two switches. I didn’t put them in a group or anything, just created two switches under the “switch:” component in configuration.yaml.
It has put a switch toggle on the “Switch” card on the main overview page which appears to work all of them.

How can I get rid of this?
I tried both “control: hidden” and “show_header_toggle: false” statements under “switch:” but neither of them are valid configs.
How can I get rid of this toggle?


show_header_toggle: false


Hi- I tried this, but it breaks configuration.yaml:

  show_header_toggle: false
  - platform: command_line
        friendly_name: 'Aeotec Z-Stick Disco Light'
        command_on: 'echo -e -n "\x01\x08\x00\xF2\x51\x01\x01\x05\x01\x50" > /dev/serial/by-id/usb-0658_0200-if00'
        command_off: 'echo -e -n "\x01\x08\x00\xF2\x51\x01\x00\x05\x01\x51" > /dev/serial/by-id/usb-0658_0200-if00'
  - platform: mqtt
    name: "Pool Pump"
    state_topic: "stat/poolpump/POWER"
    command_topic: "cmnd/poolpump/POWER"
    availability_topic: "tele/poolpump/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
    payload_on: "ON"
    payload_off: "OFF"
    optimistic: false
    qos: 1
    retain: true

This is the error:
Configuration invalid
Error loading /config/configuration.yaml: while parsing a block mapping
in “/config/configuration.yaml”, line 96, column 3
expected , but found ‘-’
in “/config/configuration.yaml”, line 97, column 3

Am I missing something? From some searches it looks like that header toggle option is only supported under “entities:”?

Not sure why it is grouping my switches together and adding this toggle.

That’s the wrong place to put

show_header_toggle: false

It should go in the lovelace file.
you can just press the config ui button and click the card. There is an option to disable the header togle.

In the group, add the “control: hidden”

Thanks Pippyn I triued the Config UI and edited the card, and that did the trick, but it appears to have broken the “Updater” card. Is that expected?

Hi af950833- What had me confused is I never added them to any group. I just put two switches under “switch:” in configuration.yaml and it grouped them together and added the header/group toggle. There was no group to add that control: hidden option.

updater.updater only shows up when there’s an update available, otherwise it doesn’t exist.

Yes there is an update available (0.88.2 because I am on 0.88.1). It was working OK until I enabled the Config UI, and then it began showing this error.

FWIW, the updater entity is now working again. It appears that when I enabled the config UI it reset that entity and updater.updater was gone. After about an hour it reset itself again and updater.updater is now appearing under developer tools > states. I guess there is a default one hour update check period where this entity gets added.