How do I manually start hass from an AIO install?

Hey guys,

So uh, I installed using AIO install last night. Seems to have worked, so yay!

However I rebooted and tried the following:

sudo systemctl status [email protected]

but I’m getting nothing in response.

[email protected]
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

However I can see HASS is online since I can access the network location (mypilocation:8123). What gives?!

What about the output from
sudo systemctl status home-assistant.service
without @pi

Ah, that’s it! Sorry, I did my previous install manually.

Could someone explain the difference? Is it just the location where AIO installed HASS?

It allows the service to be run in multiple instances. For example, the same script could be used with different usernames or sockets.

This is a copy-paste from systemd.unit manual

Optionally, units may be instantiated from a template file at runtime. This allows creation of multiple units from a single configuration file. If systemd looks for a unit configuration file, it will first search for the literal unit name in the file system. If that yields no success and the unit name contains an “@” character, systemd will look for a unit template that shares the same name but with the instance string (i.e. the part between the “@” character and the suffix) removed. Example: if a service [email protected] is requested and no file by that name is found, systemd will look for [email protected] and instantiate a service from that configuration file if it is found.

To refer to the instance string from within the configuration file you may use the special “%i” specifier in many of the configuration options.


edit: https://superuser.com/a/393429 has a good answer to this

How can i view the HA service output ? (like the message received by HA)

If the service runs with user home-assistant: sudo journalctl -u home-assistant -f

1 Like

Thanks !! Didn’t know that !