How do I remove media player devices from Alexa Media Player integration:

Tags: #<Tag:0x00007f32635f9c58> #<Tag:0x00007f32635f9a00>

Alexa Media Player integration:
I have been using google but got a echo dot to play with. I installed the alexa media player the recommended way by using Hacs and then adding with the front end integration. NOT MANUALLY
My question is how do I remove Select amazon media devices I dont want in Home assistant? (they are at another residence.)
I was able to remove the entities but I need to remove SOME of the devices.


Thanks for you help in advance.

Did you find a solution? Having the same problem.

See Exclusions Section

Thanks. But where can I find this section, I installed via HACS? Just adding everything to configuration.yaml would not work, I guess?

Currently Alexa Media Player supports configuration using either configuration.yaml or by using the UI Integration, (I don’t think it supports both at the same time), but it plans to deprecate its use of configuration.yaml, so I would recommend using the UI Integration way. When using the UI Integration way, I recall that the pop-up window where you add your configuration information also contained a line for players to exclude. If you already have Alexa Media Player setup this way, you may have to remove it and add it back.

I’ve been looking for that screen where I can configure those exclusions. I think there was a field called “exclude_list”. Now that I’ve successfully configured Alexa Media Player, I can’t seem to figure out how to get back to that screen.

When using the UI, I haven’t done this yet but I recall someone saying the only way is you have to remove the Alex Media Player integration and add it back in to get the exclude list to show up again.

OR…(what timing as I just got a notice I have to re-authenticate Alexa Media Player)
When you re-authenticate, the pop up window provides the include/exclude list

An alternative is to find the player’s entity in HA and disable it.

Thanks for the quick reply !

I recently got that screen as well, as I needed to re-authenticate. Which I did, but didn’t think about excluding players until JUST after I clicked “OK”. Sigh. I’m now going through the effort of removing and re-adding the integration to see if I can make this work. Because I have WAY to many devices.

Unfortunately, now I’m getting this :frowning:

image

I think I’m getting somewhere. Tried a normal (web) login to my amazon account, and they were pretty excited about resetting my password. Which I did. My integration works now, and through the magic of the “find” command, I can see it modified my ./config/.storage/core.config_entries file. and sure enough, EVERYTHING is in there. My amazon password, plus the “include_devices” and “exclude_devices” lines. Going to try modifying that file to slowly add devices

Yup, totally works ! I edited ./config/.storage/core.config_entries, added another device to “include_devices” line of that config_entry, restarted server, and now I have two devices, wahoo !