How do I remove Z-wave sensor entities?

Hi - something that has annoyed me forever is all the sensor entities that are created when I add a Z-wave device. Many of them don’t work, and most of them I don’t care about. But I can’t figure out how to get rid of them - they clutter up the GUI and take up space (and performance) in the history / logbook database.

For example, when I add an Aeotec nano dimmer, I get all of the following, none of which I need or want.

I’ve tried removing them from the inbuilt entity registry, but they reappear at next hass restart.

I’ve also tried excluding them in the Z-wave config area, but this does nothing at all:

And I’ve tried both together, but they just keep coming back.

It’s very annoying - our electrician will soon be installing a large number of these, and I really don’t want to have to put up with all the crap that will be generated.

Any help would be appreciated!



The “Exclude this entity from Home Assistant” writes into a file named zwave_device_config.yaml. It expects that you’ve included this in your config.


See also:

1 Like

Goodness - that was subtle. But thanks!

1 Like