How do I start a completely new zwave network?

I can’t get my new Razberry zwave board to function with HA.
I have installed HA on a new Raspberry and I used the hassbian image.
I have installed both openzwave and openzwave control panel though the hassbian-config.
In the log when I start HA I get:

WARNING:openzwave:Z-Wave Notification DriverFailed : {'homeId': 0, 'notificationType': 'DriverFailed', 'nodeId': 255}

And OZWCP complains about “No homeId”.
Where do I set the home id?
Or how do I get a new zwave network started?


This is a RaZberry/Raspbian specific problem. I assume you’re using RPi3 which is equipped with a Bluetooth radio.

The Bluetooth service and a couple of other services need to be disabled in order to free the /dev/ttyAMA0 port. There are several approaches to this problem.

One way of doing this is to install the Z-Way software you automatically got a license for and then disable the autostart service of Z-Way. You’ll also find alternative solutions in this forum.

1 Like

Wouldn’t it be better if you rename your ports through udev rules instead of freeing up names? Otherwise every reboot there is the chance that they get renamed.

THan for the tip.
I’ll look into that. :slight_smile:

This happens a lot with USB sticks, but not with GPIO devices. Creating a udev rule will create an alias rather than renaming the port and will unfortunately not work with RaZberry. If that was the case RPi3 users would’ve been able to use both Z-Wave (RaZberry) communication and native Bluetooth communication at the same time.

Hmmm… I had the problem that both my rfxtrx and a ftdi cable where alternating between /dev/ttyusb0 and 1. After creating the alias in udev and including the new names in Homeassistant (and some other scripts) rebooting wasn’t a gamble anymore.

I got it to work.
Thanx for the help.

I installed the z-way application and disabled the automatic start of the services of z-way.
After that HA started z-wave drivers without any problems and I could add and remove devices from HA.

Sweet. :slight_smile:

Thanx again.

how did you disable automatic start of z-way?

I did:

sudo update-rc.d z-way-server disable