How does Popp / Danfoss Ally TRV adaption run work?

Hi! I have 3 Popp TRV’s which are the same as Danfoss Ally. I figured they seem to react strange with regarding to temperature and setpoint, and thougth it might something to do with the “Adaption run”.
There are 3 items exposed over Zigbee2MQTT:

  • adaptation_run_status
  • adaptation_run_settings
  • adaptation_run_control

Right now i have 1 TRV on “Found” status, which seems ok but I cannot get the other 2 to run a decent adaption run to get to the same status. Initiating an adaption run will get “In Progress” and after a while “None” or “Lost”. How to run a valid adaption run with this TRV?
I did already reset the device, remove and add to Z2M, change a lot of parameters, but no success at all. Found this ZHA script, but I don’t understand enough of ZHA to make it work with Z2M. Any help would be appreciated!

Have you tried changing the batteries?
Adaptation runs are quite heavy on the batteries and if the batteries are a bit worn out then they may fail on the run and once they have regained some power be back up again.
The failed run could also be frim other things like the valve not moving to fully open or fully closed or just being too heavy to move.
Your device should make an error visible then and if it has a display then there.

Thanks for the idea.
Unfortunately changing the batteries did not help.
Overnight one of the TRV’s reached status “found” automagically, which leaves one with “None” (the one with the new batteries…) and me not understanding how this works. I do not have any error on the TRV screen.
Any help appreciated!

Not sure how the TRVs report in, but I know that Danfoss Ally have a learn-in period. Maybe it is that period that have to finish or maybe it is just a complex network that needs to be mapped fully first.

1 Like

Thanks! Indeed, waiting solved the problem it seems… Now I have them all on “found”.

Bought another couple of these TRV’s lately, but even after waiting more than 2 weeks the “adaption run status” is still on “none”, whatever I did. I tried replacing batteries, flipping the “adaptation_run_settings” or “adaptation_run_control” setting, changing other switches and values, nothing seems to trigger a decent adaption run. For now it is no problem as it is summer, but before winter I would like to learn how to get those TRV’s into status “found”. Or is it because of summer that the adaption can not be found???
Any ideas?

You might not be able to start the adaption run automatically.
You might have to press the button physically.

How to start the adaption run by use of the button? I only know about the mounted / unmounted state.

Page 12.