How strong is your z-wave signal and what have you found that messes with it?

I’m having some Z-Wave connection issues, so first, I’d like to hear from people about what they’ve found created problems with Z-Wave setups and how they got around it.

I’m aware that a Raspberry Pi has USB interference issues with some Z-Wave devices (like the Z-Stick 7). This is in a different kind of small computer. I’m thinking I should add a USB hub so I can move the Z-Stick away from the computer, just in case.

But I’m also concerned about walls. Here’s the plans for our barn/guest house. It’s a two floor renovated barn. (Check the two images for the 1st and 2nd floor plans.) The exterior walls on the 1st floor are cinder blocks and a concrete floor. (With 2’x2’ tunnels under the floor marked in green.) I was hoping all that concrete might make the signals bounce around so signals would go all over the barn without issue. But I’m having trouble with signals crossing 22’ of an empty room!

The interior walls are normal drywall and 2x4 stud walls. The 2nd floor is plywood over trusses with no insulation in it. The doors are in blue, the interior walls are in yellow.

The computer, running Linux, with an Aeotec Z-Stick 7 plugged in, is in the workshop, on the 2nd floor. It’s near the top right corner of the room. I have no trouble with the light switches near the doors for the workshop and my wife’s studio. There’s NO communication and I can’t add the light switch at the foot of the steps. I can add the light and fan switches below the computer (in the upper right corner of the great room). I could also add the switches in the office/study (now a guest bedroom), the bathroom, and kitchenette.

I had serious problems with the Schlage locks on the doors, including the one on the 2nd floor. It’s got empty space between it and the computer - mostly 22’ of air, and it still won’t connect. I plugged in an Aeotec Z-Wave range extender in the te great room, near the door in the upper left hand corner on the plans.

Still, the switches on the 1sst floor, at either end of the building, are either not seen at all or have poor communications with the Z-Stick.

As of now, solutions I’m considering is getting a 2nd range extender and maybe trying them both upstairs toward the ends of the building. Another idea is using a USB hub to move the Z-Stick away from the computer, in case of interference.

I started building the mesh network from the devices closest to the computer, but the devices at the end of the building still aren’t connecting well (if at all). Nothing is more than 35’ from the computer. It may be through the floor or stud wall, but not through anything like concrete.

Update on this, in case anyone’s looking.

I set up a Raspberry Pi 3 with a Z-Stick 7 (from Aeotec) and got it working. The Z-Stick is in a USB hub so it’s at least 1’ away from the Pi, to prevent interference. I put it in the same place as the other Linux computer. It had problems with the same devices. Considering it’s 3 locks and 6 dimmers and fan controllers, I don’t think it’s faulty devices. I also have TWO Aeotec range extenders set up - one on the 1st floor in the great room and one in the workshop (so they’re above each other). That should make that one end of the building well covered, but it’s doing nothing to help make things work.

I moved the Pi downstairs and it had line of sight with one of the door locks, about 30’ away. It knows there’s something there, but it can’t communicate with it, other than to label it Node 19 and to know it can lock and unlock. I can’t control it through there. There’s a light dimmer right near it and it can’t connect with that, either - won’t even see it when I add it.

I took my other computer and set it up near the wall (to the right on the plans) in the 2nd floor workshop and put a Zooz Z-stick in it. It was able to add a power strip down on the 1st floor that Aeotec couldn’t communicate with. I reset the lock on the loft door, which is about 7’ from the computer with the Zooz Z-Stick in it, and there was really poor communication there, too.

So the devices on both ends are not talking to the Z-Sticks. Could there be a reflectivity problem from the concrete/cinder block walls? (But that’s only on the first floor.) I find it interesting that other than a switch in the stairwell, the only devices with problems are at the ends of the building and even with range extenders, they still won’t work.

Anyone know of a good Z-Stick or Z device I can use that has a strong signal or a range range extender with a strong signal?

I’m also emailing Aeotec about this and calling Zooz. (Impossible to call Aeotec!)

I’m open to any ideas on this!

RF propagation patterns are weird and behave in really unintuitive ways. That said, if there are communication issues at 7 feet direct line of sight, then there is definitely a problem somewhere. That’s not normal, at all.

I have a ZStick 5, so the generation before yours, with worse range and lower tx power. My house is a traditional farmhouse built of huge compact granite stone blocks sometime in the 1400’s with walls that are around 1 meter thick. They absorb RF like sponges. 2.4GHz wifi is a nightmare. 5GHz, forget it. ZWave and 433MHz work relatively well due to the lower frequency and better penetration behavior. I have quite an extensive ZWave network spanning across the main house and a second smaller house attached to it (formerly the stables). The Pi with the Z stick is in the smaller house. So it needs to pass two of these stone walls to get to the main house. In that setup I get around 12m (around 40’) range indoors when all routing nodes are disabled. The blind spots of the house are then taken care of by two range extenders. Outside I get around 30m with one outer wall between the stick and a sensor. Dry walls are not an issue, neither is wooden framing and non-conductive roofing. Metal studs can be a little problematic if your sensors are placed close to them. Reinforced concrete will definitely be an issue. Metal roofing will be a huge issue if your antenna is close to it. Aluminum coated insulation too.

Did you try a minimal setup outside of this barn of yours ? Like only the Pi + stick and a single sensor somewhere across your yard in direct line of sight. Just to rule out some weird signal propagation in the building. If the problem persists, could there be an external source of signal interference on that frequency ? Nearby cell tower, neighbors with misbehaving RF alarm devices, things like that.

Oh and before doing any range testing with locks, make sure they are properly paired first. When pairing a lock, the ZWave controller will reduce tx power to limit the potential of signal interception when doing the crypto key exchange with the locks. So you will need to hold them really close to the stick for pairing.


I’ve wondered if part of the issue is that these devices are right near the wall and that there could be a bounce from it and that might create problems - but it doesn’t happen with devices in the side walls of the building.

Side note: That sounds like an interesting place to live - except when you’re dealing with RF or running cables!

So it sounds like even with those issues, you are getting a Z-Wave net to work. That’s good news for me, in the long run.

I tried to build my network from inside out and had devices added on both sides of the stairwell before I went down and tried to add the dimmer at the bottom of the stairwell - and it wouldn’t add. (I has an “add on switch” to make it a 3 way switch. I need to see if I can put the main Z-Wave one upstairs, near other connected devices, to make it work.) But adding devices moving outward from the computer has not made a difference. Even the range extenders make no difference!

That’s a good idea! If I can reach them from outside, I can always work out something like mounting a Pi or repeater - well, extender - outside. There are places I can do that and protect them from the weather. I can also use a long extension cord (I have 25’ and 100’ cords) to test things out from different places. I think I’m going to take my still unused Z-Stick and make a testing system with another Pi 3 I have. I can add one lock to it and see if I can find places where it works well with the lock.

What bothers me (and, obviously, you, too) is the problem the Zooz Z-Stick had when only about 7’ from the lock. That’s on the 2nd floor, so it’s above the cinder block walls that only come up to the top of the 1st floor. It did add the lock, but it can’t control it. It took a long time for it to interview it, too.

I have 2 range extenders and 3 Z-Sticks as it is, without ordering more. I’d need another Pi or two if I were to use them throughout the barn, but if I could get it working, I’d consider that acceptable. Expensive, but if it works…

Excellent point! While they’re communicating enough they’re being read as a device (with only “Node 2” as the node name), they’re just really weak. I don’t know if this impacts the “Re-interview” function, but if it did, that might explain the locks. (I still have a few dimmers and fan controllers acting up.) I have wondered if, when a device is having that much trouble communicating, resetting it and removing it and re-adding it might make a difference.

I bought 8 of these Schlage locks. The house has 5 and they have all been added without issue. The gap from one is as far as the gap across the room in the barn and it goes through a wall, so I know it can work from the distance involved. I also realized I have 2 leftover Z-Wave switches. I may try replacing one or two of the problem switches to see if that makes a difference, but I don’t expect it to and it’s a pain to do.

One other point: I’m thinking of moving the extenders then healing the network to get it to re-route everything. If I can use two extenders on one side of the barn and get things working, then I at least know I can do it - it’ll just cost a few bucks.

And just before I hit “Reply,” it hit me that I would have loaded up all the house locks from one battery source and the barn ones from another. So maybe I need to put in fresh batteries…

I mean it’s not impossible. Maybe there’s something in that wall that reflects the signal. Maybe a rebar mesh in the concrete.

In the end, in the absence of specialized and expensive testing equipment, the best way to troubleshoot situations like this is by elimination. I have the feeling that you’re trying to do too much at the same time to resolve this - which is understandable, you just want the thing to work after all :grinning: But you really have to go at this methodologically. One by one until you find the culprit - or a combination of several ones.

I would really start super simple. Pi3 + ZStick on a small extension cable and one other device on the far end (not a lock, locks are weird !). Outside, direct line of sight, no repeaters. See if it works, see how far the range goes. If the problem does not go away, it might be a software issue or external interference. You already ruled out hardware failure by testing on multiple sticks.

If it works in this simple situation, proceed one by one. Put the ‘problem wall’ in between stick and node. See how it affects the range. Compare with another wall. Bring the simple setup into the barn, but without changing anything else - including the distance between the stick and node and the orientation of both to each other (antennas are directional !). Observe if the range deteriorates when you have both inside vs outside. Then try with a lock. Then with a repeater. Write down the results of each test. It might take a little time and effort, but it will give you a very clear picture what causes issues and how you can circumvent them. If the wall in question really turns out to be the problem, you can try to lure the mesh around it by carefully placing repeater nodes in strategic places. But before doing this and throwing more money at more repeaters, you need to know the root cause of the problem.

Certainly is ! Funny thing, the problem with running cable is actually what got me into home automation in the first place, I just needed some wireless light switches :yum: If I knew the rabbit hole I was getting myself into… :woozy_face:

At this point I’ve put a Zooz in my other computer and it’s 7’ from one of the locks and it’s still having problems. This evening I’m going to put some fresh batteries in the lock and see if that makes a difference. (The Zooz has added one item the Aeotec could not add.)

I don’t know if having both active at a time will create issues - if so, then I need to turn one off while working with the other one.

When I start with an issue like this, I’ll see if there’s a broad, easy fix. So I might try a few major changes, but if that doesn’t work, then I start focusing on one thing at a time. I’ll have to check if I still have that long CAT5 cable I had - I haven’t been using wifi. I’ll need one or the other for this test.

When we built this house, I made sure I ran all the data lines and put in phone lines, CAT5e or CAT6 cables, and coax everywhere I might want a connection. Same with the barn. The barn also has two 2’x2’ trenches (in the blueprints) that were used as waste disposal troughs (yep, they were filed with pig shit!). I planned out the downstairs so all the plumbing could go through one of those trenches. (Now that we poured a layer of concrete over the buckling slabs, those trenches are tunnels.) Also, I have data lines going through those tunnels, but they’re fiber. I tried CAT6, but since it’s all concrete there, the wires picked up a charge and blew out equipment!

Also, when the house was built, I made sure they had extra wall boxes in some places so I could get home automation switches in them. For instance, in the great room, there are 3 switches (2 light, 1 fan) and it’d be hard to fit an extra piece of equipment in there - easier to put something like that within the light fixture. But the great room has a vaulted ceiling, so we have a wall box where I can add home automation controllers to the wiring without climbing up a floor and a half to get to the fixtures.

New information:

Since I wasn’t going to be able to do much for a few hours, I picked “Heal Network.” Hours later, when I looked, using the web control panel for ZWaveJS2MQTT, it showed EVERY node connecting directly to the Z-Stick. That was a surprise; not at all what I expected, so I went down to check it out.

Two fan controllers that were up against the wall near the porch were working and I could control the fans, which I could not do before. I still had trouble with two Z-Wave dimmers and, on a hunch, I replaced one with an extra dimmer switch I had and it added to the network quickly. So I tried the other one, the switch down at the far wall, near the front door. Once I put in a new switch, it added to the network without any trouble. Also, while swapping the switch, I realized that the actual Z-Wave element of a 3-way switch was in that same wall box - both of then within 6’ (probably 4’) of one of the locks that’s not working.

Now all the switches are working. What’s not working are the locks. I factory reset one lock, then did the basic setup on it. After that, I removed it from a door and put it near my Z-Stick:

Note it is within inches or centimeters of the Z-Stick. Even there, it would add, but the lock would report it as not added and I’d get only this on the HA phone screen:

It took a number of minutes before any other entities showed up. Re-interviewing the lock took a long time and even after that, HA could not control the lock.

I did another factory reset and took it up to the house. Since the Z-Stick up there had 5 locks of the same model working, I figure it’d add okay and prove it wasn’t the lock. Again, in the house, it took a long time to add. The re-interview took over 20 minutes. When it was done, I could not control the lock - which was sitting just inches from the house Z-Stick.

It looks like the locks are bad, but it seems odd that out of 8 locks I ordered, as many as 3 were bad AND that I just happened to put the 3 bad locks on the barn doors and not one of them on a house door.

You’re making progress !

Don’t rely on the graph from zwavejs2mqtt, it’s basically useless and misleading information beneath a pretty interface. Contrary to what one might expect, it doesn’t actually show the routing between the nodes. What it shows is just a basic neighbor graph. So if a node is shown as connected to another node (or the controller) in that graph, it just means that the node has seen that other node sometime in in the past. It doesn’t mean it will actually route the signal over it, nor that it actually could (because the signal might be too weak to do it). The actual route taken may be completely different, even over nodes that are not shown as neighbors in the graph. This is a known issue with the graph. Better ignore it completely.

That’s weird. Did you buy these locks in separate batches or all at the same time ? It could be a difference in firmware. Open the device on the zwavejs2mqtt device list, then open the version tab. Compare the info of a working and a non functional lock and see if you can spot any differences.

I got it WORKING! All of it!

I figured the odds that 3 out of 8 locks weren’t working was rather high. (I still am surprised that 2 out of 10 dimmers were bad - I’m wondering if there’s some other reason they weren’t working.) Add to that the 3 just happening to be the ones I put in the barn, and I figured it’s possible, but VERY unlikely. While Z2M is documented, the explanations aren’t always too in depth or clear. I had not set the authorization fields and it had not occurred to me that those things weren’t being automatically taken care of by HA.

I looked up the Z-Wave info on Z2M and when I saw the section on the A2 authorizations, it hit me that the lock had to be added with secure inclusion and that locks might require more security, so I created keys (and saved them elsewhere for protection). I found that you have to have those keys in the system when you include the lock. You can’t add them after the lock has been added. (I had to remove the test lock a few times and do a factory reset on it to be sure about that.)

Once I created the A2 authorization keys (and saved them to the system), the locks added much faster than before and worked. I did have an issue with one lock. I realize the locks are kind of set back in the wall, so even with two switches right near it, it jus seemed to not get a signal if the door was closed. (It worked fine when it was at least partially open). It looked like the range extenders weren’t being used. (Yeah I saw what you said about the Z2M mapping - but I was also judging by what devices were working now and the distance involved.) I reset them and removed them from the network, then put one in a spot where it had a direct line to the problem lock, even if it was going through drywall.

So now all devices are working properly!

Considering the locations - that all the uncooperative devices were at the ends of the barn, I had applied Occam’s Razor and figured it was likely one cause. It wasn’t. It was two bad dimmers, the need of authorization keys for security for the locks, and one lock just being in a bad spot.

Oddly enough, I put all Z-Wave switches in the barn, but not in the house. Our house was designed to have a look and feel of being kind of timeless and like a fairy tale. While we have older style flip on/flip off switches, I’ve been hoping to replace them with old style push button switches some day. For the barn, I just went with newer (in the US - they’ve been in use for decades in Europe) flat switches (I think they’re referred to as paddle switches). So the barn has more Z-Wave devices than the house at this point.

I have a box full of Insteon dimmers and fan controllers. (In many ways I like Z-Wave better, but there were a few reasons I went with Insteon at the time. One was availability, since the electrician was supposed to put them all in when wiring the house, but they confused him!) The next step will be adding these devices to the house. I think I’ve hit the major issues for Insteon and Z-Wave, including Z-Wave on a Z2M system at this point. I don’t think I’ll be adding anything Insteon based in the barn.

I am curious about Insteon’s dual mode system. The house and barn come off the same breaker panel, so I’m wondering if an Insteon device in the barn would be easily controlled through the powerline by the PLM in the house.