How to access files in Ubuntu VirtualBox?

Hello, I have set up home assistant on a Linux VirtualBox on my Windows 10 computer and I am wondering how can I access the configuration.yaml to configure it, and all the other files??

I tried FTP but can’t connect…
I tried with these settings:


Can somebody help me?

By default, the root user on Ubuntu is disabled. You need to SSH in as the user YOU set up during the Ubuntu installation. You will also need to make sure openssh-server is installed, it’s not by default.

I used the virtual disk download in the installation guide page:

Used this disk: VMDK (VMWare Workstation)

And followed a YouTube tutorial…

So I have no clue what the username is… :persevere::persevere:

But that’s not Ubuntu…

Haha. Well, because I created a ubuntu virtual machine, I thought that was ubuntu. Lol.

So, can you clarify what that is?

How do I access the files then, or how should I install it to be Ubuntu?

It’s HassOS. It’s running the regular Home Assistant OS.

You access the files via the frontend, using the UI Editor, or you enable the Samba addon, or the SSH addon and access them that way. You can also use VSCode + the HA Extension.

You do not “install it to be Ubuntu” because HassOS is its own OS. It shares nothing with Ubuntu but the fact it’s running a linux kernel.

Okay, that was the part I was missing: the ash plugin. Gonna do it right now.

Am I still gonna need credentials to access it over FTP with that default installation once I add the plug-in?

There is no FTP. It runs SSH or Samba. Not FTP. SFTP runs over SSH port 22.

Yes, you will need credentials depending on what option you go with.

Ok man, thanks for your help and availability!! That was really helpful. I’m gonna try to figure it all out from here. :smile:

Oh man, feels embarrassing to bump here but:
WinSCP_MFQ0RduNiA WinSCP_meDwstjBkm

What am I doing wrong??

It looks like you’re confusing things here.

Your config shows that you set up SAMBA, and you’re trying to connect to it using SSH/SFTP. These are completely different protocols. If you want to connect using SSH/SFTP, then you need the SSH add-on.

As it stands right now, you can just connect using your normal Windows file explorer/browser

I feel dumb. hehe. I just ended up using the web file editor. And I’m also following the documentation now. Something I should be doing from the beginning.