How to add a Z-Wave device

Here’s where I’m at: I have a raspberry pi 3 running home assistant with openzwave. I have an Aeon labs gen 5 stick installed on the pi and i’m not getting any error messages.
My first z-wave device is arriving later this week. It is a Aeon Z-wave smart energy switch, it’s basically an extension cord with a z-wave switch built in. I’ve been looking for an easy to follow guide on how to pair a z-wave device with my controller with my setup. but at this point i really am not sure if home assistant program will automatically detect or if i have to do something to manually pair.
If anyone has any experience with this i would be super appreciative of some help!

There is a couple of ways to pair your devices with the controller, but the easiest way is to trigger the service zwave/add_node in HASS gui and enable pairing on the device. There is usually an instructions manual with the device. And that’s it. The device will appear in the gui after that


I just added a Aeon Labs gen 5 this past weekend to my Ras Pi2 and it couldn’t have been easier. Just as mentioned above use the zwave/add_node in HASS under the development tools and enable pairing on the device. It showed up in a card however I did need to restart HASS to have it work properly and it’s been working great ever since.

Wow… Thank you so much. This will be so easy compared to a lot of the suggested ways to pair devices that i’ve read about so far. Are there any downsides to pairing this way? And will it maintain being paired after a reboot?

No downsides at all. Every way of pairing will have the exact same result. It’s just a matter of convenience.

About the reboot it’s a bit inconsistent. The pairing will always happen with your controller, but sometimes OpenZWave is having trouble identifying the node and all its sensors at first. A reboot of the application implementing OpenZWave (home-assistant) often solves that.

Edit: misread your question about rebooting, but I let it be there because it have some informational value.
Yes, your device is paired with your controller until you unpaired it or perform a factory reset on either controller or device.

One thing to note -

In my setup at least, I have been getting very unfriendly names for the devices such as light.linear_unknown_type4754_id3038_level_2 - HA tries to make that into a more friendly name but the end result is still very uninformative. Fortunately you can fix this using the customize function of the homeassistant block in config.yaml, e.g.

      friendly_name: Kitchen

And it will turn up as “Kitchen” in the UI.

Also, an alternate way of pairing that I found effective was to pull the stick out and walk to the new device. Then press the button on the stick once (it has a battery built in for this purpose), and enable pairing on the device. If successful the stick light will flash rapidly for a couple of seconds. Then rinse and repeat with the next device. When the stick is returned to the Pi and HA restarted, all the newly paired devices will show up automatically. This approach worked well for me as I had about 15 devices to pair.

The downside about this method is that some devices require a “secure” pairing that is not supported via this method. This might result in home-assistant crashing if a secure-device is paired in a non-secured network.

Interesting and good to know - what type of devices typically need this? I have paired smart bulbs and light switches/dimmers so far with no issue.

It all depends on the devices implementation, but it would be devices that have some sort of association with security. For instance I have some fibaro smoke sensors that require secure pairing.

1 Like

Is there any way not having to restart Hass after adding a z-wave node? add_node work fine for me, but I would like to not have to restart Hass. Tried “refresh_node” after adding the node with add_node but that did not help…

(new in this community, not new to Home Automation, old Vera Lite migrant)

Is not clear to me how to pair with the aeotec stick.

The Zwave device manual says to put in pair mode the stick and then press the button on the device. But the instructions for the stick are not clear (to me)


So the correct way is

  1. Add node in hass
  2. Put stick in pairing mode (how?)
  3. Press button on device to pair


If your Z-Stick is plugged into your Home Assistant machine, then calling zwave.add_node will put it in pairing mode. If you unplugged it, then you use the button to put it in pairing mode. So the steps are:

(Plugged in)

  1. zwave.add_node
  2. Press button/switch/whatever that you’re pairing
  3. (Maybe?) restart HASS



  1. Push button on stick
  2. Press button/switch/whatever that you’re pairing
  3. Plug stick back in
  4. (Almost certainly) restart HASS

Ok, now I got it, it works