How to add and rename Z-Wave devices


I probably do it wrong, but adding ZWave devices is quite hard, while it should not, and the network works quite well.

I received a bunch of Aeotech Window Sensor Gen5 I want to add. Here is my current workflow to add them:

  • prepare a coffee, open one box, prepare everything.
  • in ZWave, click on “add node” (does it make sense to use “add secure”?), and then click on the association button on the ZWave stuff.
  • ZWave stuff led says everything is cool, and in Home Assistant I see a new device named “Aeotec ZW120 Door Window Sensor Gen5”. Fine, HA got it. HA is very clever, HA will make my life easier.
  • “access_control” entitiy is updated when the sensor is activated. Great.
  • but… their is no “door sensor” by default, I have to define a template for that? :frowning:
  • But first, I want to rename it so that all entities of the devices so that they does not have _1, _2, and so on. Since all entities have the same name than the device + “_access_control”, _burglar", …, if you change the device name, the entities will follow. And no :frowning:
  • So I manually edit the device name. All my entities kind of disappear from the Z-Wave panel, so I suspect a mismatch in xml/config file => I restart HA.
  • after several minute, I find all the entities with the old name “” I want to rename to sensor.[sensor_location]_[entity_type] (where entity_type is access_control, buglar, and so on).
  • restart HA again, edit my “binary_sensor template” to have a clean door sensor. Why is that I have to add a virtual device in order to “see” my_window_sensor_access_control as a door sensor:
  - platform: template
        value_template: "{{ is_state('sensor.kitchen_window_sensor_access_control', '22') }}"
        friendly_name: 'Kitchen Window'
        device_class: door
        entity_id: sensor.kitchen_window_sensor_access_control

        value_template: "{{ is_state('sensor.tv_room_window_sensor_access_control', '22') }}"
        friendly_name: 'TV Room Window'
        device_class: door
        entity_id: sensor.tv_room_window_sensor_access_control

Sometime not all entities are “found”, I have have restart HA again, and if it does not find all entities again, to remove/add the device again. So at the end I have to restart HA 3 or 4 times per device.

Why do I miss I find using Z-Wave devices is soo hard with Home Assistant ? We do not have the ZWave Panel integrated in HA like it is in Domoticz, so debuging is quite hard.

So I do one sensor a day to keep my blood presure low. But that’s so close to have a perfect support, simply some kind of “wizard” that ask you questions such as “name of your device”, and “do you want to see your door sensor as a door sensor?” and if you anwser yes, the “template” (or alike) is created automatically.

generally if the device is secure then you should use “add node secure”. but if the device doesn’t support security the adding it securely will still work and it will just default back to non-secure.

how are you editing the device name?

if you go to the entity that gets automatically created and click on it there will be a pop up box and in there will be a gear icon in the top right. if you click on that you should be able to modify the entity_id and friendly name of the entity.

it’s not ideal since you have to do that for every entity of the device but it’s been like that now since around v76 and it’s not going to change. but at least now we have a way to change the info from the gui. that just got finalized in some recent versions so for around a year we didn’t have an easy way to do it. you were forced to do it by manually editing the entity registry files. at least there is some progress.

i don’t know about the aeotec stuff but on my neo door sensors i think i needed to change the “report type to send” in the z wave control panel to “binary report” or something like that. then that created a binary sensor to use directly instead of needing to create one in a template.

all of this is by memory so i could easily be mistaken on some or all of it. :slightly_smiling_face:

trust me - i feel your pain on the z wave stuff. it does seem to be way harder than it needs to be.

just got hard of the entities in my device… removing zwave devides is really really hard :frowning:

And now to have it working, I had to restore the zwcfg_0x????.xml to its previous state before the inclusion to have it readd all the entities…