How to add devices using Conbee II

I have just started with HA, and running it in Raspberry pi4.

I think I have managed to add Conbee II in HA, but how to add devices to it.
Phoscon app does not find the Smart+ Plug (Ledvance) that i am trying to add (first).
Nor Hue Smart plug… Nor IKEA Dimmer Switch I had lying around

I am currently using Hue bridge, but I am tossing it, and need to move all devices to HA eventually. Can see all my stuff under Hue in HA, but I am not going to use Hue much longer.

So, the question is how to add thingies to zigbee net created by Conbee?
Or…how to make sure that Conbee is installed correctly?

1 Like

If you delete a device from the Hue app it will go into pairing mode and the zigbee stick will be able to find it. If you’re using ZHA, go to the co-ordinator’s device page and click “Add devices via this device”.

For other devices, you have to put them into pairing mode manually. With switches and plugs it’s usually just a case of holding down the button until the light starts flashing.

If removing from HUE app, means outside of HA…and using the original app used with hue, that is the whole reason I had to start searching for alternative ways to control thingies.
Phillips in their great wisdom made an “update” to the hub and it no longer is reachable via Hue app, unless ports in the router/firewall are opened, and that I am not doin.
There are also automations running in Hue hub that I cannot edit or remove because of this.

I think I can reset all devices in Hue´s net to factory settings…but first I would like to succeed in adding few of those gadgets that are not currently in Hue before attempting to remove those that are still functioning in Hue.

And truth being told, I have no idea what I am using (meaning about ZHA). I have just installed basic installation, and deCONZ, because that was the instruction in Conbee…

In my opinion skip Deconz, use Zigbee2MQTT or ZHA.

I am open to any suggestion, but since im a noob with HA and other stuff related that i have in this project (raspberry, conbee) I need a bit more detailed information.

For example adding MQTT integration asks for parameters I have no clue at.

For Zigbee2MQTT: GitHub - zigbee2mqtt/hassio-zigbee2mqtt: Official Zigbee2MQTT Home Assistant add-on

ZHA: Zigbee Home Automation - Home Assistant

Guide on how to use Conbee2 on Z2M Supported Adapters | Zigbee2MQTT

I think I managed to install MQTT and it is in configured section in setting. Didnt get any errors, should think it would be a walk in the park from now on, but…

…I sure am a noob in this, have tried to add devices by resetting (this time IKEA thingies), but cannot get them to appear anywhere. If I choose to add IKEA trådfri, it wants numbers from the hub, so that atleast is not the way :smiley:

Zigbee2MQTT addons WEB UI wont open, always gives either of these errors
" The add-on is not running. Do you want to start it now? "
When pressed run addon comes this:
“The add-on seems to not be ready, it might still be starting. Do you want to try again?”
Latter sometimes comes straight away from trying to open WebUI

Some times can kinda advance with retry…but then just blank screen appears

When getting back to addon page, it shows that addon is stopped, even though it was running when open WEB UI was clicked.

Check the logs. Have you configured:

  adapter: deconz

Make sure nothing is using the conbee (ZHA, Deconz), make sure it’s mapped correct /dev/serial/by-id is best but you can also use /dev/TTYUSB0 and so on (check what yours is, Settings → System → Hardware → All hardware → find the Conbee).

I have that adapter line in config, and I found it to be


since no other can be used, using


Gives error in editor right away

But still, no change in behavior.

Have tried all suggested configs I found, just to test it, but for some reason config always returns/resets to this:

data_path: /config/zigbee2mqtt
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: “-d -d”
log: false
mqtt: {}
adapter: deconz /dev/ttyACM0

and the log that comes with this is:

[13:09:11] INFO: Preparing to start…
[13:09:12] INFO: Socat not enabled
[13:09:14] INFO: Starting Zigbee2MQTT…


Refusing to start because configuration is not valid, found the following errors:

  • serial/adapter must be equal to one of the allowed values

If you don’t know how to solve this, read Configuration | Zigbee2MQTT


Have tries changing false to true, but that wont do anything either

you need to edit the configuration.yaml in the zigbee2mqtt folder. Easiest is to install the visual studio code addon and browse to it there.

Zigbee2MQTT is configured using YAMLopen in new window based configuration.yaml file. The file have to be located in the data directory within your installation. The data directory and the configuration.yaml has to be writeable for Zigbee2MQTT process because it can get updated - e.g. if you change the settings in the frontend. It’s possible specify a custom data directory by setting the ZIGBEE2MQTT_DATA environment variable.

visual studio code is now installed…

the configuration.yaml file in the /config/zigbee2mqtt directory has nothing related to the earlier mentioned code i have in Zigbee2MQTT option boxes, but 35 lines of something totally different.

Starting to think that I have in my hands more than I can chew, and i am about to toss this whole idea (of rasperry based system) in the trash.

If I had a working hubs (ie. HUE) and just like to use them via HomeAss, I might have enough energy to put it together…but this is just too much for me, when i have to ask practically every step just to get the zigbee net up and running (which is still not). Can imagine the horrors to come when actually need to configure something else.

Thank You for Your effort to help, but I give up now…life is just too short for this

Paste the contents of the file and I can check it for you later tonight.

I am using HA + Deconz + Connbee II and I seem to remember that it Just Worked. Once I told HA where Deconz was and authenticated it, that was it, everything in Deconz became an entity in HA.
One thing that should appear even if you have nothing paired is the synthetic ‘Daylight’ sensor - do you see that in Phoscon and HA?