How to add vibration to the button on iPhone?

I spent a couple of days to set up my Lovelace UI. It’s a great UI - I Love it! Thanks for the great work. One quick question: is there anyway to add the vibration after the button is pressed on my iPhone? Somehow I couldn’t find the “enable vibrate” under the profile menu. Thanks a lot in advance for your help!

Below is my simple ui-lovelace.yaml:

          - type: "custom:button-card"
            entity: switch.hotwaterkit
              action: toggle
              action: more-info
            icon: mdi:kettle
            name: Hot Water
            color: auto

Are you sure there is no button on the profile page? When I go to my profile page, there are three buttons at the top “Always hide the sidebar”, “Vibrate” and “Push Notifications”, do you not see this options?

Which iPhone?

iPhone models that support haptic feedback include the iPhone 7 and 7 Plus, iPhone 8 and 8 Plus, the iPhone X, XR, XS, and XS Max.

I have an iPhone Xs Max with iOS13.1.13. Below is the screen shot of my profile page - I only have the “Always hide the sidebar” and “Push Notifications” but not the “Vibrate”. Very strange…

I have the same as chenghs on an iPhone XR. I confirmed haptics were allowed in settings too.

Haptics are only implemented in a few key places at the moment and it only works in apps (the official iOS app at least and I believe Ariela), not browsers like Safari or Chrome. You will only see the enable vibration switch if your app supports haptics.

I see it in Firefox

I see that switch also in the browser but in the v2 iOS app I do not see the toggle at all. But I do feel some haptic feedback when pressing buttons.

My phone is Xs. I tried different type of card in the last couple of days. If I used “custom:button-card” as type, there is no haptic response in LoveLace UI. If I changed it to “entity-button”, I do feel the haptic response when click the button. Is it just me having this issue - no haptic response using “custom:button-card”? Thanks,
Merry Christmas!!!

I can confirm see this behaviour as well.