How to Arm Stay Instant Total Connect 2

Hello, all - I am able to arm (stay, away) and disarm my total connect 2 system with HA. All works great. However, one thing I am not able to do is to Arm Stay Instant (which is sometimes called Night Arming). When I use Arm Home via alarm_control_panel.alarm_arm_home (which is Arm Stay), with the #7 or +7, it always performs the normal Arm Stay (not Arm Stay Instant). It seems to ignore the optional code. Whether I use the optional code or not, it always seems do arm stay normal (not instant).

I also tried the night arming service call via alarm_control_panel.alarm_arm_night with and without the #7 or +7 but in either case, I get the following error in the logs and no arming occurs.

I am attaching screen shots of the script step for both of these cases. I am thinking that there must be specific notation to enable this but I could not find. Any help is appreciated.


2021-08-09 10:24:16 ERROR (SyncWorker_8) [root] Could not arm system. ResultCode: -4520. ResultData: None

2021-08-09 10:24:16 ERROR (MainThread) [homeassistant.components.script.activate_night_arming] Activate Night Arming: Error executing script. Error for call_service at pos 1: TotalConnect failed to arm night Home.

2021-08-09 10:24:16 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [139683314771616] TotalConnect failed to arm night Home.