How to assign a device to an area

All automation software that I have played with has areas. So does HA, but I have yet to find how to assign a Z-Wave device to an area. I can create areas and I can view a Z-Wave device’s properties, which include area, so can somebody tell me where I can edit the area?

Go to Configuration -> Devices, select a device, click the gear icon and select the area.

Note: this is for 0.105 where they changed things a bit. If you are on an older build, it might be a little different.

3 Likes

Found it. Thanks!

I use the fibaro hub integration, although this let’s me control all the fibaro connected devices i am unable to find a way to put different devices in different area’s (can’t find a way to add them to an area anyway).
All the devices integrated via the fibaro hub integration are found under “Entities”, but not under “Devices”.

Is there a way to get this done?

4 Likes

Have the same issue: Yeelight needed to be added manually to configuration.yaml. The light now shows up as entity and is not assigned to a room. It does not show in the devices list.
So I cannot figure out how to assign the room.

Any ideas?

3 Likes

Devices can be assigned to Areas (and therefore all entities which belong to an assigned Device will also appear in the assigned Area)

An Entity without a parent Device cannot (as far as I know) be assigned to an Area via the UI. (Perhaps there’s some YAML which can override this?)

Like the OP, I can’t seem to find a way to move devices from one location to another. I’m new to HA and have been adding my lights in locations, but when I want to move them to a different room, no option shows up under the gear icon. I’ve been through the Supervisor and Configuration menus. The screen shot is attached of all I see for the gear options. What am I missing?

image

And additional info: this light I’m trying to switch rooms is already assigned to a room [has a Parent Device].

Sorry, nevermind. I found it. Was a different Gear Icon on the device page.

Oh, the gear is way up on the right hand side of the header. I was expecting it to be near the device name or in the device info box. Got it now.

For the entities which are not bound to an device is not possible to link them to an area.
Would love to have these via integration or via manually editing the config files. Both options are not feasible. Any suggestions?


I have the same issue. I’ve just installed Home-Assistant and added the manual integration of the Fibaro controller in configuration.yaml as per instruction. It finds all Z-wave devices and adds them and they show up in Lovelace.

However, they are not added as Devices but Entities, and I can’t seem to add them to an Area. IMHO Z-wave devices should be found and added as Devices. A Multisensor (for instance containing a Motion and Lux sensor), should be added as a Device. The Entities of that Device are Motion and Lux. The Device should be able to be added to an Area, and the Entities (Motion and Lux) should thus also be added to the Area of the Multisensor. Then we would be able to see the sensors in the area.

It also eases the naming and view of devices. If you have 20 Multisensors in different rooms, but they all show up in a row as now, it is difficult to view, and name. If we could put the device in an Area, the name does not matter so much as you mainly view the Area of interest.

Hope it will be implemented, and soon

1 Like

Kind of a similar problem here: I have a KNX bus here, but as far as I understand the KNX integration is not yet configurable via UI. So I added it to my configuration.yaml and added a simple on/off light to my config. This also shows up in the UI as an entity but not as a device so I cannot assign it to a room.