How to bypass Philips hue motion sensor cooldown

Here’s the scenario: Enter room - motion detected and light comes on.

Exit room - hue motion stops Detecting, light goes off

Enter room again within a minute of the sensor switching from on to off- motion is not registered. How do i get it to start detecting motion and turn light on right away

I’ve looked everywhere to find an answer

Thank you,

How is the sensor connected? Via the Hue app or otherwise?

Most motion sensors have a fixed cool down period.

One exception is the aqara P1. You may want to look at this.

My Hue motion sensor reacts immediately when motion is detected, even if it went off just before.

I got it setup on the Philips hue app first and then I added it to home assistant using the Philips hue bridge integration

Have you deactivated the control in the Hue app?

I disabled it like you said in the hue app and made sure the sensor configuration were turned but no luck with it turning back on right away


It’s really weird
when the light shuts off, the motion is set back to clear, if i step in front of motion it will be set to detected and the light won’t turn on but If i let it set back to clear again and then step in front of it again it goes back detected and turns on right away

I hope I explained this right lol

I appreciate you troubleshooting with me on this

Got a bunch of Hue motion sensors here and never seen this type of behaviour.

Did you buy any of your Hue stuff second hand?

I have a bunch of hue motion sensors. All connected directly to HA as a zigbee device (i’am using ZHA).
All these devices have a cooldown periode but thats only about 10 seconds.

No I bought it off amazon brand new

I’m using the hue bridge to communicate with the hue sensors. Are you using a zigbee dongle to communicate to these devices?

yes, I use a conbee II dongle

I’m using the bridge. What are your ‘Do this after the timer’ settings set to? Perhaps a screenshot of your motion sensor settings could help?

Not sure if it helps, but i had a similar problem with my Ikea Tradfri motion sensors, but after a recent zigbee2mqtt update I found that it can nowadays be configured in settings:

I thought you were using the Hue app for your automation?

I’m using the hue app bridge integration in home assistant

I should of been more clear my bad

It’s a bit tedious to read without automation code, anyway, which mode is selected, restart? If not, I would try with that.

I just purchased the sonoff zigbee dongle and I’m going to connect it through zigbee2mqtt like you’re saying and see if I can get these setting for it.

Thank you!