How to change the layout

That’s not a valid parameter for MQTT switches so it needs to stay in customize section. Are you using lovelace or the old interface. It’s very interesting that you are getting these lightning bolts by default. I have 100s of switches and do not have assumed_state set on any of them. All of them come through as a toggle. But according to the docs assumed state affects the display. Maybe this setting isn’t set properly by MQTT switches.