How to change the layout

Hi, I’am new to HA and I made already some Yaml sensors and switches that I can change with a esp8266 and mosquitto.
On my Ha panel, I can see the switches and a group switch. But the icons are different in shape. See the included picture!
So how can I make all the switches the same glide switches (icon) and not a group glide icon and the rest a lightning icon to switch.

CTRL+F5 in your browser

Sorry i’am new. When/where are you doing CTRL+F5

On your keyboard, when the browser has focus

ok, sorry I know the buttons CTRL + F5. But I mean with where => Is it in Hassio card configuration that I have to go, to change the Icons or where do I have to be before I do the CTRL + F5.

The control button on your keyboard. And the F5 button on your keyboard. I’m not sure how else to spell this out. Hit them at the same time. Or Hold CTRL and press F5.

EDIT: There’s no config for this. It’s typically a browser refresh issue. If they are switches they should show up as a toggle.

Ok The ctrl + F5 is not the thing I don’t understand but before you push those buttons you have to login to Hassio.local:8123 . Then You see the Hassio panel in your browser and then you see… ( see picture)

I don’t like to the lightning switches and I like to change them all to the gliding switch, like you see on the top right general switch

Do your switches report a state? If not, then it’s not possible.

This is the Yaml in the configuration.


  • platform: mqtt
    name: “Living spot tv”
    icon: mdi:lightbulb-on
    command_topic: “ha/living0”
    state_topic: “ha/living0”
    payload_on: “ON”
    payload_off: “OFF”
    optimistic: true
    qos: 1
    retain: true
    #value_template: ‘{{ value.x }}’

  • platform: mqtt
    name: “Living spot haard”
    icon: mdi:lightbulb-on
    command_topic: “ha/living1”
    state_topic: “ha/living1”
    payload_on: “ON”
    payload_off: “OFF”
    optimistic: true
    qos: 0
    retain: true
    #value_template: ‘{{ value.x }}’

So when you look at the device in the states page, it has a state?

Is it this?


Yes, now turn on the light and turn it off. See if the state changes in that menu.

yes. that is working

Then it’s a refresh issue. There’s no setting for the lightning bolts. They only appear if home assistant cannot resolve a state. You have a state so the toggle should appear. Try CTRL+F5 again on the browser you are using. Make sure that the ‘bad’ switches are visible and the browser has focus.

If I use my esp8266 connected with mosquitto, then I can change the state of the switch on the panel and in the statepage. The lightning on the Ha panel goes then to the right when the light is on and back to the left when the light is off. The general switch goes to the right, if there is minimum 1 light on and back to the left if all the lights are out. So everything is working fine, except that I like to have a switch icon and no lightning icon. If I use now The CTRL + F5 or not there is no diffenrence. I just see that the browser is refressing.

Not sure what to tell you, there is no configuration for the lightning bolts. They only appear if it doesn’t have a state. You claim it has a state. So either you have the only broken version of home assistant or you are doing something different than what you say.

And to clarify. If you have a state the toggle will appear. I.E. what you keep referring to as the

I just update to ha 94.4. But I had that also before.

anyway I like to thank you for the help.

I don’t know what there could be wrong.
But I found with Customizing entities => assumed_state: false , that could be a sollution but I don’t see the change on the panel.

If you just placed that param in the customize section you have to restart HA. Only the lovelace.yaml file will allow for changes without restart. And if that parameter does in fact bring the toggle, browser cache will hold on to the old style and you will have to clear that and reload. Which is CTRL+F5. Browsers are a pain.

ok I put the => assumed_state: false in the configuration Yaml. So I have to put it in the customize yaml.

now I have a look how to do it… thanks.

Dinner is ready, I have to go.

Thanks, everything is fixed with => assumed_state: false in the customize.yaml

Is it not more logical to put it in the configuration.yaml together with all the rest of the configiration of the switch?