How to configure preferred Thread network

Hi all, this is me probably being stupid but I’m not sure how to choose my preferred Thread network in Home Assistant.

I have a Skyconnect installed and Multiprotocol support is enabled for the device.

Under integrations I have the SkyConnect showing along with an Open Thread Border Router and a Thread integration. When I go to configure the Thread integration it says at the top ‘you don’t have a preferred network’ and below that under an other networks heading i’ve got two networks showing, NEST-PAN-05EE (Google Nest Hub) and Open Thread (Silicon Land multi protocol). Is the Open Thread shown here my Skyconnect?

Do I need to choose one of these as my preferred network, and if so how do I go about doing this?

I currently don’t have a Thread device but am looking to get one in the next few weeks so was hoping to understand the process before hand.

I assume to add a Matter/Thread device I’d go to Devices > Add device > Add Matter device and then be able to scan the qr code with my phone.

I’m also on the latest HA 2023.3.0


I was asking myself the same. I have a HA Yellow and have the same issue…

After upgrading to HA 2023.3, go to setting > devices, remove the OpenThread device and restart HA.
Your Skyconnect will become your preferred OTBR


Hi Stephane

Before I do this do you mean the integration called Open Thread Border Router in my image from original post?

The one at the top of your image
OT Open Thread Border Router

It will be recreated automatically when you restart and will become your preferred router


Thanks so much, this is set up great now

discovered this discussion and I have similar issue as @Daniel-W , but I do not have the Open Thread border router appearing. FYI, I have skyconnect plugged in on my HA

I am trying to configure the open thread router by inserting the internal IP address of my Apple TV but it failed to connect…

so not sure what I can do now

I found the answer now, I had to enable multi-protocol for skyconnect, then it worked

It is possible to use my Apple thread border router as preferred network?


That’s my question too. Or at least, is there a way to delete the apple thread routers?

So I’m guessing the other TBRs are shown because they respond to mDNS discovery with the Thread network info (_meshcop._udp) and I’m also guessing you can’t make Apple your “preferred” network because the iOS mobile companion app doesn’t yet sync the thread credentials dataset, and you can’t provision new devices without that.

I noticed the latest Android companion app now syncs Google’s Thread mesh credentials to HA, so I wonder if you can make that your preferred network after syncing, has anybody tried it?

You can indeed do that after the Android app synced the credentials, however my main question now is, how do we get Sky Connect in the same Thread network than the Google Nest / other devices?

There’s a “Add to my network” button that asks to reconfigure the border router, but for me proceeding triggers the error of ZHA being on another channel.

Failed to configure the border router
Can’t connect to network on channel 18, ZHA is using channel 15

  1. Is there a way to change the Google Nest channel anyone found? I understand changing the Zigbee channel of a full formed network through SkyConnect is not possible.
  2. Has anyone managed to add Philips Hue as a matter device? Wiki here says it’s a known problem it won’t add, that is getting fixed in 2023.3 but not too sure that happened!
  3. 2023.4 for me added a further home-assistant network with no devices inside, do we know what is that for?
1 Like

I still don’t understand how you made the “nest-pan” your preferred network. Can you explain a bit more please?

As for the “home-assistant” have you turned off multi-protocol support on your slyconnect and then added the OTBR add-on.

If you are using multi-protocol the thread network is on the same channel as the zigbee and it cant be changed to the channel the nest-pan is running on.

Did you get a response to this, as I have exactly the same question/problem, and I didn’t see an specific answer to your question?

I’m running Home Assistant Yellow, and when trying to configure Thread, it claims I do not have a preferred network ! My only option to seems to be to add an OpenThread BR. However, there is already an existing Thread network, formed by three Apple devices acting as border routers. Why can’t I use this? (They’re on some fictitious network called MyHome72 - where this name came from, I’ve no idea, and I’d love to change it if I knew how, but that’s another topic.)

How do I configure HA-Y to use this existing Apple Thread network as my preferred Thread network. (I see no point in creating yet another one.) Is there some config in HA that needs to happen?

Thanks in advance.

1 Like

I’m looking to combine my Thread networks into one.

I have a HA Yellow with a seperate SkyConnect running the thread firmware. It’s working correctly and I have some matter devices connected and functioning.

I also have Apple TV’s and a Google Nest Hub that I’d like to combine to provide a better thread coverage across my home.

Is this possible?


I have the same setup that I’m trying to get working with a Home Assistant Yellow with a separate SkyConnect. So I’m interested in the answer about combining networks with my HomePods too.

Also how do I go about changing the channel on the SkyConnect as at the moment both ZHA (on the inbuilt Zigbee radio) and Thread (on the SkyConnect) are using the same channel.

Although I’ve spent a considerable amount of time trying to learn Thread/Matter, I’ve still more to learn, so I may be a little bit incorrect here, but … my understanding at the moment is that the basis of a Thread “network” is a network made up of devices that have a common Thread “dataset” (“dataset” contains things like credentials, radio channel, etc.). So If you want to have HA’s OTBR/Thread/Skyconnect on the same Thread network as the HomePod, then one somehow needs to get the Thread dataset from the Apple BR and provide it to HA’s OTBR/Thread/Skyconnect for it to operate with.

Currently, getting the thread dataset from an Apple BR is a problem. Ideally the Apple BR would have some API for HA to use to get the dataset, but I don’t think one exists. The HA companion iOS App would be another candidate for getting at the dataset, since it has this ability, but as I understand it, Apple has not given NabuCasa/HA permission to do this yet. The only way thus far I have heard to solve this problem is to build a “dummy” device that can be added to an Apple Thread network, which once joined will get the dataset, and then somehow one can extract the dataset from this dummy device.

Since HA/SiLab’s Multiprotocol requires both its Zigbee and its Thread stack to use the same RF channel, I think what you mean by this is that you want Multiprotocol on Skyconnect to use the same channel as the HomePod … So if somehow you can get the HomePod Thread dataset configured into Multiprotocol’s Thread stack, then the dataset will tell Multiprotocol’s Thread stack what channel to use. If it differs from ZHA, then I think you can configure ZHA to use that channel.

Best Regards


Thanks for the comprehensive response Tommy. It sounds like there’s a way to go before the thread network functionality becomes robust. Originally I planned on just using the HomePods as BRs. However I’ve found at random intervals the thread devices drop off the HomePods’ thread network - requiring me to re-pair and unpair the devices from HomeKit again, then adding them again to HA.

For the second question, I’ve got two separate radios - the Silabs radio in the Home Assistant Yellow and a second one in the SkyConnect. I bought the SkyConnect before I decided to buy the HA Yellow but in the end decided to keep it so I could set the network channels independently for Thread and Zigbee. So I’m currently using ZHA with one radio and the Openthread Border Router with the external SkyConnect radio. Unfortunately I’ve not worked out how to set the thread channel.

I did a write up on how I changed the thread channel. In that write-up (see below), I did not have any Thread devices, just the Multiprotocol AddOn OTBR. If you already have Thread devices attached to the AddOn’s Thread network, I’m not entirely sure it will work, but it does have the potential to work.

1 Like

Perfect… looks like what I need. No thread devices attached at the moment - so not an issue.