How to connect Aqara Smart Lock U100 to your Home Assistant

I just got my m2 hub and u100 lock yesterday and have noticed the same behavior! You are absolutely correct. I believe aqara is holding the certificates for the matter connection on a cloud server and not on the device itself. That would absolutely mean that if they decide to stop support for matter or close up for whatever reason then we wouldn’t have access to the lock in home assistant anymore.

I tried connecting the lock to homekit in home assistant but it doesn’t show up in homekit only the hub itself shows up. I’m so annoyed did a lot of work to get this lock and hub setup and my door configured only to now have to return everything. No sense in keeping it I’ve been burned too many times with IOT crap like this never again.

I wonder why no one else has noticed this. Maybe and update changed the way the hubs work I’d also be interested. E1 guys test this out!

I did one more test to see if I could narrow it down further…

I had a spare Aqara Temperature/Humidity sensor lying around, so I paired it to the M2 hub. It immediately appeared in the Matter integration in Home Assistant as a device paired to the M2. It also showed up in my Apple Home app since that’s connected via Matter, too.

Then I repeated the prior experiment of disconnecting the M2 Hub’s internet connection and rebooting it. The result was the same for the locks (unresponsive), but the temperature/humidity sensor continued to function normally. So it appears that the M2 Hub continues to operate locally after a reboot for some devices, but not for locks. And this confirms the Matter interface itself survives the reboot.

After some further reading, I suspect the U100 may be like the A100 in that the Zigbee interface is actually Zigbee Smart Energy (encrypted) and requires a key/certificate for the hub to establish a connection to the device. It also seems that this encryption key is needed every time the controller reboots, not just at the time of device pairing.

If this is the case, that explains the behavior I’ve observed. Not making the encryption key available for devices that are offline seems like a pretty big miss from Aqara :frowning:

So the U100 is useless without the cloud and needs the hub for HA. The lock was perfect in many ways, I wanted to get the M1S do to the speaker and ring light.

So there is no way to keep the hubs offline and keep the lock functional?

Definitely don’t want my door connected to the internet.

After having my locks installed for a few more weeks now, I’ve decided I’m going to keep them. It is inconvenient to have to allow the hub to have Internet access whenever it’s power cycled, but that happens very infrequently, so it’s not that big of an inconvenience for me.

In this case, the features and functionality of the lock outweigh the possible risk that Aqara could shut down their servers in the future. That’s a personal decision, though… not for everyone.

If I were looking for a way to have the locks fully functional without any Internet access after the initial set up, I think that could be done.

After setting up the locks with Bluetooth and the Aqara app (using an anonymous email address), that would allow things like fingerprints, passcodes, NFC devices, etc. That’s all stored locally within the lock. Then, you could register the device with Home Assistant directly as a HomeKit device via Bluetooth. That would get you the basic lock/unlock/status functionality directly in Home Assistant without a hub and without Internet.

You wouldn’t have Apple HomeKey or be able to integrate it with Apple Home, as HomeKit devices can only be paired to one controller at a time. But this would give you full local functionality of the lock and visibility and basic control through Home Assistant, all without Internet.

1 Like

I thought adding it to HA with Homekit via Bluetooth doesn’t work that well and eventually stops working after a day? This is based on other threads I’ve read.

I don’t need HomeKey, all I want is to be able to setup the fingerprints via the app and have it available in HA for checking status and using HA to lock/unlock even if its slow over Bluetooth.

This is promising if it works reliably, hopefully it works with BT proxies.

I tested it briefly with it connected to Home Assistant directly as a HomeKit device via Bluetooth. For the couple hours that I tried it, it seem to work well, provided the lock had good signal quality in its installed location. I have not tested it thoroughly in that mode, though.

Currently, I do have the locks connected to Apple Home both via Matter and Bluetooth simultaneously. That means there are two lock entries for each physical lock.

The Bluetooth version of the locks in Apple Home are slower to respond and to update status vs. the locks that are connected via Matter. But I haven’t had them go away entirely.

Apple home key NOT working. I have HomeKit tied to the U100 and the M2 hub. I have Matter working. I am able to lock and unlock from HA and HomeKit. But I cannot seem to get Apple home key working. The MANAGE ACCESS menu option is not there. I am guessing that I needed to bind to HomeKit from the Aqara app? In that app, I go to properties → other platforms and HomeKit says NOT BOUND. When I try to follow that and find it, it tells me to ADD ACCESSORY. It wants to Scan a Setup code. But I have no idea what code it’s looking for. As I am in the Aqara app. My Apple TV is the hub for HomeKit, and it doesn’t have a code printed on it anywhere that I could find. Any idea how to do this?

From the manual (emphasis mine)

Add the Device to HomeKit (for iOS users)

After the door lock is powered on for the first time, click “+” at the upper right corner of the Apple Home app in the iOS, select “Add Accessory” or open Aqara Home app. Tap “Bind HomeKit” in the “General Settings” column of the setting on the detail page of the door lock. Scan or manually input the HomeKit code as prompted (HomeKit code can be found when you open the battery cover of the indoor door lock). Then add users according to the instructions. HomeKit only supports the lock and unlock, smart automation setting and Apple Home Key.

So far haven’t seen that here, which I’m very glad of. We get far too many power interruptions in town that would otherwise drive me (even further) up the wall.

@Graybound , thanks for the explanation. I was able to connect my home assistant to the Aqara U100 lock using the M3 hub (PoE) after a lot of pain.

I tried with E1 but no deal. Did everything but every time I ended with this in my Matter log:

2024-06-08 22:00:39.879 (Dummy-2) INFO [root] Established secure session with Device
2024-06-08 22:00:40.007 (Dummy-2) CHIP_ERROR [chip.native.CTL] Failed in verifying 'Attestation Information' command received from the device: err 101. Look at AttestationVerificationResult enum to understand the errors
2024-06-08 22:00:40.007 (Dummy-2) CHIP_ERROR [chip.native.CTL] Error on commissioning step 'AttestationVerification': 'src/controller/CHIPDeviceController.cpp:1145: CHIP Error 0x000000AC: Internal error'
2024-06-08 22:00:40.011 (Dummy-2) CHIP_ERROR [chip.native.EM] Failed to send Solitary ack for MessageCounter:228022510 on exchange 48660i with Node: <0000000000000000, 0>:src/messaging/ExchangeContext.cpp:99: CHIP Error 0x00000002: Connection aborted
2024-06-08 22:00:40.012 (Dummy-2) WARNING [root] Failed to commission: src/controller/CHIPDeviceController.cpp:1145: CHIP Error 0x000000AC: Internal error
2024-06-08 22:00:40.012 (MainThread) ERROR [matter_server.server.client_handler] [139975136721552] Error while handling: commission_on_network: Commissioning failed for node 2

Returned the E1 hub, acquired the M3 and it worked flawless!