How to disable Camera integration (with FFmpeg dependency)?

I don’t know when it started but for a while I’ve add this error in the logs when Home Assistant loads:

[homeassistant.setup] Setting up camera
[homeassistant.loader] Loaded ffmpeg from homeassistant.components.ffmpeg
[homeassistant.setup] Setting up ffmpeg
[homeassistant.setup] Setup of domain camera took 1.0 seconds
[haffmpeg.core] FFmpeg fails [Errno 2] No such file or directory: 'ffmpeg'
   Traceback (most recent call last):
     File "/srv/homeassistant/lib/python3.8/site-packages/haffmpeg/", line 136, in open
       self._proc = await self._loop.run_in_executor(None, proc_func)
     File "/usr/local/lib/python3.8/concurrent/futures/", line 57, in run
       result = self.fn(*self.args, **self.kwargs)
     File "/usr/local/lib/python3.8/", line 854, in __init__
       self._execute_child(args, executable, preexec_fn, close_fds,
     File "/usr/local/lib/python3.8/", line 1702, in _execute_child
       raise child_exception_type(errno_num, err_msg, err_filename)
   FileNotFoundError: [Errno 2] No such file or directory: 'ffmpeg'
[] Error starting FFmpeg.
[homeassistant.setup] Setup of domain ffmpeg took 0.3 seconds

I haven’t given it that much thought since I’m not using or have installed anything that should need FFmpeg. But today when I tried to silence this error I realized that I appear to have a Camera integration installed by default that from the looks of the error above requires FFmpeg.

I don’t need any Camera integration, and I don’t need or want to install FFmpeg. How can I disable this integration or at least silence this error warning since it’s not applicable for my setup?

Here’s a (closed) related ticket for it:

If you really don’t need it, check if you have a line, inside your configuration.yaml file with


If you have it, comment it changing to


After some days, if nothing bad happens, you can delete this line

I have the same problem.
I have not any cameras in my installation but I have a camera integration.
Why is it installed and how can I disable this integration?

Well late to the conversation, but I have a “fix” that works for me.

  ffmpeg_bin: /usr/bin/true

I don’t have space for ffmpeg and all the dependencies, nor do I have a need for it. Calling /usr/bin/true silences the error message in the logs.