How to do a clean install of Home Assistant without the usual tools?


My first post here, certainly not my last. Initially alot of questions, but in due time, after lots of time and experience i hope to even be able to contribute :slightly_smiling_face:

I got myself a nice T640 thin client, without keyboard/mouse.
I used Balena Etcher on an old HDD and booted Home Assistant on it. No problems there.

Initially i managed to install all the smart devices that i have at home, also managed to make it work in Apple Homekit. However, i truly made a big mess of everything and now i would like to start and do it in a nice and neat way…

The problem is, how? How do i format the SSD? Or, how do i reinstall Home Assistant again?
I have tried to boot it up again and i was to see it installs Home Assistant again, but all my mess is still there.
Ive read about deleting the /config which i did, but this did not clean up Home Assistant…

How to do this with little no no tools, no keyboard/mouse, only a external HDD, a Maxbook AIr and a win10 laptop?

Hope someone can point out the right direction :slight_smile:

Why can’t you just do what you did the first time?

Thats what i did;

-ppwer dwn the computer
-insert HDD with HAOS image and power on
-Watching how HAOS installs itself

When complete, i still have my old setup in front of me… all devices, settings, it is all there.

I am however now trying something else. I make a Ubuntu boot, installed it and managed to go -without keyboard - to Disc Utilities. In that menu i am able to format the HDD storage.
Only annoyance is that i only have one storage, so i have to put back HAOS again afterwards…
Will update if i managed this to work :slight_smile:

If you’re doing a fresh install, it’s not possible for this to happen.

What is a fresh install exactly?

What i tried is: Turn off the computer, insert the boot device, turn on the computer
In this case there wasnt ‘preparing Home Assistant’ - screen, or a screen in which the application requests you to make an account / passowrd, etc… It installed in less than 2 minutes and when it was done, the old situation was still there. No fresh slate, no clean installation. I have no idea why this is the case

Nevertheless, i managed to fix the problem and i am currently watching the installation happening. Totally fresh!.
What i did? I installed Ubuntu on the HDD, and used it to boot up the T630 with it. I did not fully install it but i choose the option ‘Try Ubuntu’. Once i was in the system i went to Disc Utilities and choose to format the SSD…
Once this was done, i flashed the HDD with HAOS again, and booted up the system…

Problem solved,… but surely a strange, a unnecessary one… HAOS should have a delete/factory-restore option…

Not meaning to sound rude, but you must have been doing something wrong. A fresh image of HA via balena cannot be anything other than that!

1 Like

I find it reallly strange it doesnt work.

The HDD (boot device with HA on it) is inserted when the computer is powered on. It is installing like the first time, but only one difference and that is that all my old settings and devices are stilll there. I do not know what step i am nissing here

I don’t know what you’re doing wrong, but if you’re flashing a drive using Belana it will delete the contents of the disk before writing the new image so there is no way for the original installation to still be on the disk. This isn’t an HA issue.

Why don’t you plug a keyboard in?

I know… i should have… cleared out my attick as i thought i had one… but no.

Luckily i managed to solve this issue by installing Ubuntu and using the Disc Utilities to format the SSD,… after that i flashed the HAOS again and …a fresh install :slight_smile: