How to enable Home Assistant to find the IP addresses of all my things automatically, when my router is set to reboot every 24 hours?

Hi, I have my router set to automatically reboot every 24 hours, because I have quite a lot of things in my smart home set up that all run on 2.4 GHz and as some of you guys may already be aware 2.4 GHz tends to get ‘choked’ after a while if too many things try to connect to it at the same time. A reboot can resolve this and a pre-emptive reboot every 24 hours can considerably lessen the frequency of this problem occurring. 5GHz would be better, but as most of my things require 2.4 GHz, I don’t have any choice.

But, as a new install and someone who is also new to HA, what I have found is that this also causes the IP of many of my things to change. For example the Philips Hue hub, My RM4-Pro, Samsung Smart Things hub and so on.

I can’t confirm that it’s the case for everything I have, but certainly, as far as I can work out the IP address for my RM4-Pro is DHCP/Automatically assigned and I cannot assign a manual IP address in the settings.

The same is likely to be true of a number of my other things. So the question is how do I get Home Assistant to automatically track changes in the IP addresses of my things, in the event of a router reboot, or a restart due to power failure and so on? Or is HA incapable of automatically tracking changes in the IP addresses of my things in this way?

Looking at the settings in the HA dashboard for my RM4-Pro (for example), it still lists the IP address from before the last reboot and the only way I appear able to resolve this, is by entering the new IP address manually again.

Any suggestions?

The best solution would be to upgrade your wifi to something with multiple access points that can handle the number of clients you have.


Or alternatively, get rid of all these wifi devices running on 2.4GHz and replace them with more secure, lower power alternatives like zwave or zigbee which don’t have as much communication overhead and are designed for that purpose instead of clogging your wifi high bandwidth network with low bandwidth devices. I did this a couple of years ago and man, what a difference it made! everything works much better both for wifi and for home automation… No more unnecessary cloud dependance was also a side benefit of it.

1 Like

Yeah, it took 5 to 10 seconds to turn on a light.

Sorry but I found zwave to be pathetic compared to the response you get from wifi devices. Also you don’t have to wait minutes for the network to initialise if you take it down for some reason (e.g, restarting home assistant). Though I am lead to believe this is now containerised and less of an issue nowadays I still would not recommend it due to the price gouging by manufacturers. Speaking of which there are none for many device types, e.g. vacuum robots, TVs, etc…

Have a read of the zwave or zigbee section of the forums before accepting this as a panacea.


Fix your WiFi and network.

A cheap and very reliable solution is a Ubiquiti AP-AC Lite paired with a EdgerouterX. I use this setup in 3 locations, one being my business which has a free customer WiFi to connect too - it’s almost bulletproof. With this setup you can manage your network better, provide fixed IPs, separate networks for IoT items and so on.

If you need to reboot something to “fix” a problem constantly, then the problem is the thing you need to reboot.


How many wifi devices do you have?

If you’re running the router/wifi combo provided by your ISP, upgrading to something better might solve your problems.

I have 46 devices connected to my 2.4GHz access point at the moment and have no problems with things getting choked up; the last time my AP was rebooted with 4 months ago due to a firmware update. I’ve found the Unifi UAP-AC-PRO handles many many connections just fine.

Also, does your current AP have the ability to assign DHCP reservations? For devices such as your RM4 that cannot be set with a static-IP, if you can assign it a static reservation in your access point, then it will always be given the same IP after a reboot.


Sorry, Not having this experience. Actually quite the opposite now. My zwave devices come much much faster than my wifi ones (And I have over 150 nodes for zwave and 2 dozen zigbee) and that’s not even taking into account the useless and abusive cloud integrated ones. It’s all a matter of mesh setup.
If you chose controllers like the “dumb thing” or debilitating ones like vera, then I can see why you had a bad experience but it isn’t because of the technology, it’s the implementation. For wifi, it is the technology that is not adequate for the application… It can be made to work but it is inefficient and clogs your wifi airtime and channels in ways which are not scalable.

1 Like

Nope, all Aeotec devices talking directly with HA via their USB stick. I mapped the mesh, it was well connected but it still sucked as far as latency went.

If you spent a quarter as much as you did on zwave devices to fortify your wifi network with a few APs instead, you may have had a different experience with wifi.

Bullshit. IoT uses such little bandwidth it’s barely noticeable. Especially as it uses the 2.4GHz band and all my high BW devices are on 5GHz - which BTW has excellent coverage as a secondary benefit due to using multiple APs.

I’m glad zwave works for you but it is not the be-all-end-all solution. Many people hate it with a vengeance with good reason. I’m one of them.


I really sincerely appreciate all the responses, but telling me to spend extra money over and above what I have already spent (and I have already spent a small King’s ransom), is exactly the kind of responses I was hoping to avoid.

But what I’m getting from this is that there is no way for HA to automatically track device IP changes in the event of a router reset? (For whatever reason, be it maintenance, power outage, or whatever?) To be fair, that would be a little bit nuts as very few routers exist that will never need resetting - and therefore if HA can’t track IP address changes of equipment in real time, this would mean you have to manually renter and reconfigure HA on every router reset?

I would rather try to make what I have work, than throw even more money chasing the elusive perfect configuration, only perhaps again to find at the end of that road, there are still issues and deficiencies I need to confront.

Putting my HA server together has already cost nearly $500 on its own. (Don’t ask, I went overboard and got the best of everything.) I’ve looked at Z-Wave and various other things, but I’m not ready to bin what I have for a potentially equally uncertain outcome.

My router is decent. It cost about £160. It’s a T-PLink something or other - and while some other devices may or may not choke with more or less devices, every router I have had so far has struggled to cope with my set-up. (There have been 3 in this last year, each being an ‘upgrade’ to try to resolve the problems with my 2.4 GHz network becoming clogged.) I only have 36 connected devices so far. That may be more, or less than others here, but YMMV, depending on your own individual set-up. In my situation, that does seem to cause some issues on 2.4 GHz.

Not sure I know how to do that. But I guess I can take a look. The problem is that this is now the third router I have bought this year to try to resolve this problem. So it’s a worry if I have to keep throwing money at new routers to try to resolve the problem. Evidently router manufacturers are aware of this problem - hence why increasing numbers of them do allow you to schedule a maintenance reboot.

Even given that some routers may only need to be rebooted every few months, doesn’t that still leave the issue of having to manually reconfigure certain devices and connected hubs - all just because of a simple router reset? Sometimes my ISP plays up - and the best way to get online again is a router reboot. I clearly can’t just live in dread of the possibility that at various points or other, I might need to reset my router for a variety of reasons. That doesn’t seem to be very sustainable.

This is the way it is suppose to work.
IP addresses might change that’s the default behaviour of DHCP. HA shouldn’t “track” IP address changes.
If you don’t want an IP address to change after a reset/reboot whatever, then:

  • use fixed IP address it the device (in many cases, it can be done)
  • define static DHCP lease on the wifi/router (where your dhcp server is) when having fix IP address is important

BTW, I have 87 IP devices on my wifi network and the last reboot of my wifi access point is 6 months old…


It isn’t necessary for HA to do so. You just need to configure your network correctly. There are two things you can do:

  1. use device host names instead of IP addresses - for example, you can configure the machine hosting your HA instance to use the host name homeassistant.local or something similar, and type that into a browser instead of an IP. That will always resolve to the same machine, regardless of what IP address it currently has.
  2. for devices where you can’t control the host name or don’t want to use one to access it, you can configure the router to assign it the same “fixed” IP every time it connects. You can then use the IP address directly and it will never change.

Neither of these things has anything to do with home assistant, it’s just part of configuring your network.

And as far as needing to reset your router every 24 hours… You may not need to buy a new one, but that definitely indicates a broken setup. Even with mid-range routers, you don’t need to reset them very often if they’re setup correctly. What do you mean when you say things are “clogged up”? Poor WiFi performance is most often caused by poor placement of the router, or not having enough of them for the size of your residence. In a residential context it is almost never due to having too many clients connected

1 Like

I mean basically that once every 2 or 3 days unless I reboot the router I lose internet connectivity. Hence when I lose internet connectivity a lot of my stuff stops working. I’m guessing that could be for a lot of reasons, but a router reboot usually resolves it.

I appreciate in your case you haven’t had to do a router reboot for some time. But as I said, clearly our usage scenarios are somehow significantly different and regrettably I do need to occasionally reboot.

Placement is not an issue. I live in what is in essence a small one room city centre apartment. There is no point using ‘extenders’ or ‘signal boosters’ or building a mesh network as nothing I have is any more that 5 or 6 meters away from the router. Besides, as I said, I’m now on my 3rd router this year trying to resolve this issue. I guess there could be some local interference on the 2.4GHz band, given my central location. But I have had persistent problems with losing connectivity on the 2.4 GHz band.

But your advice is good and I will certainly give it a go.

On point 1, is there somewhere in the interface I can make this change? If I try just typing homeassistant.local into a browser it does nothing. What would I gain by making this change?

On point 2, I’m not sure if my router can do that, but I’ll look into it later today.

Again thanks for the input.

You don’t set the host name in HA, you set the host name of the machine which HA is running on. How have you installed HA? If it’s on a raspberry pi, then set the host name of the raspberry pi. If it’s on a NAS, set the host name of the NAS, etc. You gain the ability to access your HA instance by typing a text address rather than an IP address. The host name stays the same even when the IP address changes. For example if you currently use to access HA, you could now use http://homeassistant.local:8123/ instead. Adjust if you use https or a different port.

I’ve never seen a router that could not assign fixed IPs. Just search for <router model> fixed IP address online

OK how about if I’m using a Raspberry Pi (which I am), how would I go about setting up the host name for this? I just followed the instructions, downloaded the image, burned it to a MicroSD (and bar a few adventures along the way), that was it really.

If you’re running HA OS it’s in the supervisor system panel you can set the host name but it should be homeassistant anyway. Also in the browser you need to specify homeassistant.local:8123

Yes, that takes me to the login page. One last thing though, what if I have forgotten my username? Lol. Is there somewhere I can find this? I am still logged in via the numerical IP address.

I’m still not entirely certain how knowing the hostname will improve my situation though? Do you have an example of where this is likely to help. Sorry if it’s a dumb question.

The hostname stays the same when you reboot the router, even if the IP changes.

Sure. But how will that help in my case? Sorry. I know I must seem very dense, lol.

You then configure everywhere the hostname instead of the IP. So if you reboot the router the devices will then continue to work with HA.