How to enable power consumption statistics

Thanks, will try!

No success, I have added the following into sensor.yaml as you proposed:

  - platform: integration
    source: sensor.power
    name: solar_energy
    unit_prefix: k
    round: 2
    method: left

, restarted HA and still nothing:

UPDATE:
I have checked STATES and here what I get, I think problem is with unit of measurements, will fix and report back!

Just wait a little. The integration produces results once an hour. And that kwhh I just saw :slight_smile:

All worked, thanks to you! However I do not see data on the right, it shows 0kWh,

where if I go to DeveloperTools/STATES:

it shows 0.15
any idea?

While I like the idea of the Energy consumption card, I am missing a possibility to use the Greeneye Monitor as source. This is what I use to track detailed energy use, including the main consumption. I ended up just building a lovelace dashboard.

Wait at least one hour, as said already the energy dashboard only updates once every hour.
So even though your sensor shows a value now, the energy dashboard needs some time to update.

1 Like

You probably only need to add some attributes to your sensor in order for them to be available for the energy dashboard. As this whole energy thing is pretty new, it will take some time until all the integrations adapt it.

WORKS!


THANKS!!!

Strange, after restart of the system statistics dissapear, shall it be like this?

No, my energy dashboard works fine after a restart.

Oh maybe HA switchedoff yesterday, and I just start it again, that is why all statistics for today is 0? Is there a chance to see passed days, weeks, month, YTD etc?

Hello, i have some trouble setting up the new Energy Dashboard.
I can not select the entity.

Here the Configuration:

What did i do wrong?

Thank You!

1 Like

My problem has been solved :slight_smile:

1 Like

Hi, I have a similar poroblem, my template skill are low

How to fix this? The correct energy value is here sensor.prism_energia_totale which comes from


  - platform: mqtt
    name: "Prism energia totale"
    state_topic: "prism/1/wh_total"
    unit_of_measurement: 'kwh'
    state_class: "measurement"
    device_class: "energy"

  - platform: template
    name: "house_energy_kwh"
    unit_of_measurement: "kWh"
    state_class: measurement
    device_class: energy
    state: {{states('sensor.prism_energia_totale}}  # THIS HOW TO MAKE IT WORK?
    attributes:         
      last_reset: '1970-01-01T00:00:00+00:00'

Klagio,

no need for a template sensor, this should work immediately


  - platform: mqtt
    name: "Prism energia totale"
    state_topic: "prism/1/wh_total"
    unit_of_measurement: 'kwh'
    state_class: "measurement"
    device_class: "energy"
    last_reset_topic: "prism/1/wh_total"
    last_reset_value_template: '1970-01-01T00:00:00+00:00'


1 Like

Thanks will try now.

I do have various devices that measures power not energy, I was thinking of using the integration platform. In that case I am forced to use template (hjow?)? Or can I add something


  - platform: integration
    source: sensor.efergy_802171
    name: total_energy_efergy
    unit_prefix: k
    unit: kwh
    round: 2
    method: left

Cattura

EDIT: OK this I was able to add device_class in customization, and now it works

No its now showing up in the dropdowbn menu when I add device

Cattura

Cattura

It has state_class, last_reset, unit_of_measurement, device_class, all OK? There is no reason it does not show up.

is your a question or statement? Yes to me it seems it has it all …

state_class: measurement
last_reset: ‘1970-01-01T00:00:00+00:00’
unit_of_measurement: kwh
friendly_name: Prism energia totale
device_class: energy

tried to customise with kWh (W capital letter), but no it still does not appear

Yes, no reason it should not be available in the energy tab.